BrickPi- Lego sensors- no response


#1

I got BrickPi Base Kit few days ago. I created SD card image using instructions from DI website and used it to start up. After the initial assembly, tried LED test using DEMO Hardware (for Scratch). It is not working. None of the sensors test (using Scratch)including motors are working.
I am running “V 6.9,This version was updated on 2016.03.20”. Tried Disabling IR Receiver as well.
Nothing seems to work. Lego sensors are fine with Mindstorms controller.

I am powering Brick Pi with 8 AA batteries. I see 1 red LED light on Raspberry Pi that is connected to its own power.
Not sure if the BrickPi is getting any power.
Pl help.


#2

Hey Temecula,

Is it possible to run the hardware test here: https://github.com/DexterInd/BrickPi_Python/tree/master/Sensor_Examples

You will find this on your SD card in the directory "home/pi/Desktop/BrickPi_Python/Sensor_Examples"
In there, there’s a simple script “https://github.com/DexterInd/BrickPi_Python/blob/master/Sensor_Examples/LEGO-Motor_Test.py

With a motor attached, you should see some movement. What happense when you run that in Python?

Best, John


#3

Hi John,
I ran the LEGO-Motor_Test in python. No motor movement at all. But display message in python says “Running Forward” & “Running Backward”.
What am I missing here?

Thanks.


#4

If you were using a version of the image with “Jessie” in it, there may have been a software problem we patched up last night. If you run the update on the desktop, this should solve the problem.


#5

Hi John, I ran the software update. Now the LED test works. In Python, the motor turned forward once and an error message appeared. See attached.
When I tried Motor Test using Scratch, I got some error messages. Motors did not work. See attached.

Thanks.


#6

I spent the day working on this. There is a major issue with Jessie and serial communications (we documented this and thought we had solved the issue a while back but apparently not fully). I still don’t have a full solution yet.

We’ll keep you updated on this issue and the progress in solving it. In the meantime, if you’re using Jessie, you’ll need to revert to using Wheezy. I’ll have an image up on Sourceforge shortly here: https://sourceforge.net/projects/dexterindustriesraspbianflavor/files/


#7

The sensors work now. All sensors are responding to Scratch.


#8

Good to hear!


#9

@temecula.us

What changed that made the sensors work?

Thanks


#10

I’m experiencing this issue as well.
The motor ports seem to work fine but none of the sensor ports are responding when performing the tests in Python.
Running Raspbian GNU/Linux 7 (wheezy)


#11

Hi @geekluv,

Can you tell us which all tests you performed and what were there output. Can you also double check if your battery voltage is between 9V to 12V and if you have any doubts in powering the BrickPi, refer to the documentation here. In addition to this can you run this Firmware check program and tell us the firmware version it displays.

-Shoban


#12

@geekluv, if you’re using Scratch, we recommend you use our image Raspbian for Robots. It comes with Scratch setup for the BrickPi, and you can download it here for free.