BrickPi - no LED[SOLVED]


#1

hello John,

I cannot seem get my Brickpi to work. No LEDs are lit on the Brickpi board, although the 5V regulator is working when I power from battery. Raspberry Pi powers up from either battery or USBpower.

1)The troubleshooting script(icon on the desktop?) doesn’t show any options for Brickpi…only GrovePi and GoPiGo. Is there another troubleshooting script?

2)I have been following the instructions on the website: http://www.dexterindustries.com/brickpi-tutorials-documentation/

Are there other instructions I should be following?

Is there a troubleshooting section/link?

BTW, the disk image came from Google-drive.

thank you,
Gary


#2

follow up,

Ran python Sensor_Examples LEGO-Motor_Test.py and LED.py…both worked.

So board is working and communicating via Python. <whew>

Ok, next gotta try to get to work with Scratch. Not working so far. Ran Car.sb. No movement.


#3

Hi gkridwell, I’m glad that it’s working now and the motors and everything are running.

Which version of Raspbian for Robots are you running right now?


#4

hello John,

Thanks for the quick reply.

I am running “2016-05-10-raspbian-jessie” downloaded from Google-drive.

Python works.

Scratch doesn’t seem to work correctly: when I launch, it communicates with sensors (or something…I forget the message)…but running the car.sb and clicking arrow keys on my computer doesn’t do anything. No motor movement. Nothing. I’m reading through your website to see if I can find a clue to why scratch may not be running.

thanks again,
Gary


#5

Hey Gary, no problem at all. I’m sorry this isn’t working yet. We’ll get there.

Is it possible to take a screenshot of the error you’re seeing? Is it popping up when Scratch starts, or when you run the BrickPi commands?


#6

hello John,

I figured it out. I read the documentation. :slight_smile:

StepA: Follow the steps outlined at this link, which involves launching and setting up Scratch for Robots.
https://www.dexterindustries.com/BrickPi/program-it/scratch/

StepB: From the command land, type sudo python ~/Desktop/BrickPiScratch.py

My errors were:
-omitting stepB
-including stepB, but executing BrickPiScratch.py from another directory (there seems to be duplicate copy on my Raspberry in another directory).

It might be helpful to mention StepB on this first instruction page (https://www.dexterindustries.com/BrickPi/program-it/scratch/). I had to dig for it a bit and it wasn’t clear to me whether this was a legacy command from a “pre-Jessie” version.

However, it is good to run into some bumps…I learn (and read) more. :slight_smile:

Now that the Tank is moving, I can bring the kids in on the fun.

thanks for the help,

Gary