BrickPi not making motors move


#1

Hi,

I have finally got time to play with by brickpi but it doesnt appear to be working, as far as I can see.

I have followed the steps on how to set everything up and then opened a REPL to see if I could get a motor to move. I just couldn’t!

Below is what I put and the output. I have 2 motors and neither of them are working. I don’t have anymore motors to try.

How can I see if the board is working or if it is the motors.

(brickpi)pi@raspberrypi ~/brickpi $ python
Python 2.7.3 (default, Jan 13 2013, 11:20:46)
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from BrickPi import * #import BrickPi.py file to use BrickPi operations
>>>
>>> BrickPiSetup() # setup the serial port for communication
0
>>>
>>> BrickPi.MotorEnable[PORT_A] = 1 #Enable the Motor A
>>> BrickPiSetupSensors()
0
>>> BrickPi.MotorSpeed[PORT_A] = 100
>>> BrickPiUpdateValues()
0
>>>

David


#2

Do you have a NXT, or can you borrow one to test the motors?
Do you have any sensors, and if so, have you tested those?
Have you checked the motor is connected to the right port?


#3

In order

No
No
Yes. I have tried all the ports, with both motors attached at the same time and get the same result.

I should have mentioned, I am powering my it all through the USB power for the Raspberry PI.


#4

That could be the problem. AFAIK the motors are powered by the 9V source connected to the Texas Instruments SN754410. Give it a try with a 9V block or battery pack.


#5

Again Frans, to the rescue. Can you try powering with a 9V source (and leave the USB in place), and let us know how it goes?

More detailed info on your options for power can be found here: http://www.dexterindustries.com/BrickPi/getting-started/power-up-the-brickpi/


#6

That solved it!

I want this to be fully mobile, will the brickpi+rpi get enough power from a power pack?


#7

We’re starting to ship the 8XAA battery packs. In our experience that’s been enough power to run most things, for an hour or so.