BrickPi problem with motors examples


#1

Hello, we have a problem with motors on our BrickPi.
We are working with LEGO - Motor Test.c and we have the next problem:

  • Shows this text "BrickPiSetup=0"
    "BrickPiSetupSensors=-1"
    And the motors dont move. We tried to apply more voltage ( 12v max) and it still doesnt work. We followed all the steps to program it and we dont know what can be the fail. We tried on C and Python.

We used the command “i2cdetect -y 1”

We add you this image to see that. This dont recognize the motors.

http://i39.tinypic.com/e9zzph.jpg

Thank you


#2

A few questions:

  • What image are you using?
  • Do any of the sensor examples work?

#3

We are using the latest image on the web, “2013.07.27_BrickPi_weezy_flavor.zip”.

The only example working is the LED.py. The others motors examples didnt work too. Today tried on scratch but still doesnt work.

Thanks you


#4

Ok, sounds like you’re not communicating with the BrickPi at all. The LED’s run on GPIO’s, so they’re not involved in communication between the BrickPi and the RPi.

Let’s try this: if you go into BrickPi.py and remove the first “#” from line 48 “# DEBUG = 1 # Remove to hide errors” to look like "DEBUG = 1 # Remove to hide errors "

What errors do you get back?


#5

First of all thank you for your help. We swapped our BrickPi for other BrickPi and this works. We compared these Brickpi, and we saw a extra capacitor in the last BrickPi (the BrickPi that doesnt work). Have we to power supply in other mode? Or we have to use the same steps?

Thank you.


#6

Hmm, that’s interesting. I wonder if there was a manufacturing defect. Can you post a picture of both?


#7

Left BrickPi works, and right BrickPi doesnt work.
We have 4 BrickPi, 3 like the left image, and 1 like the right image.


#8

Ok, I noted a few things in the pictures and from what you said. The “Left” BrickPi is a BrickPi Basic Power, and the “right” BrickPi is a BrickPi Advanced power.

So none of the BrickPi Basic Powers work, is that correct?

First, you’re using 9V batteries. Do you have a 9V DC source in your lab? Or do you have a 6XAA battery pack you could try?

If you have to use the 9V battery, can you measure the voltage? Is it above 7V?


#9

Sorry, my english is really bad. The BrickPi advanced power (the one who have extra components) is the one doesnt work. Other three BrickPi we have work excellent at the moment.

Yes, we have a 9V DC source in our lab, and we tried with it too. We read here we can put it on 12V max, and we tried a bit more than 9V (~10-11V).


#10

Hello Neixeronyate,
I just wanted to followup, have you had any success with this?

I still think you might have a power problem. We recently put up a new guide to powering the BrickPi here: http://www.dexterindustries.com/BrickPi/getting-started/power-up-the-brickpi/

You might want to take a look and let us know if any of the options are available to you, and if they work.


#11

We tried all options and still doesnt work. Include source 9V. We think is a communicate problem, because the other 3 BrickPi( without the advanced power) works really well.

We did the “DEBUG=1” test, and this is the result:
Running Forward
BrickPiRx Error: -2
BrickPiRx Error: -2
BrickPiRx Error: -2
Retry Failed
BrickPiRx Error: -2
BrickPiRx Error: -2
BrickPiRx Error: -2


#12

My last attachment didn’t work, trying again


#13

Can you contact us through our website here: http://www.dexterindustries.com/contact.html

We will arrange a replacement for your hardware that way.


#14

Thank you for all, we are contacting now with the website.


#15

Back to the Motor Rotate test… Trying once more to upload the code!


#16

Hi ! I have the same problem with my brickpi…

On program " LEGO - TouchSensor test.c":

BrickPiSetup: 0
BrickPiSetupSensors: -1

using touchSensor on port 1…

Did you find some issues ?

thank you !


#17

I sent my BrickPi back to Dexter Industries and got a new one.


#18

erf…i tried with new image and a new brickPi…still don’t work. I feel a bit lost :wink:

Python code is working great but C code return the error “-1”. Except for LED.c. They are blinking.

So i have 2 brickPi and they don’t work !

Thanks for replying


#19

We think we have a solution to the the BrickPi C code problem.

The way to make it work is to update the packages and the run the BrickPi setup script again. Also make sure that you have the latest C code too.

We have put together an install script that should help you with this. Here’s the link: https://github.com/DexterInd/BrickPi_C/tree/master/Scripts .

Download it and follow the Readme and the C code should work for you.

-Karan