BrickPi Problems


#1

Hi,
Just got my BrickPi advanced for Christmas and we have been having some big problems with it.

The only thing I can really do is an LED test.

When using the ultrasonic sensor It say object in range when there’s nothing in the way of it.
But motor control is the biggest concern, when I set the BrickPi to tell me when the motor moves nothing is printed to the console.

Any ideas of why this could be happening.


#2

Hey WastingLight,

Sorry to hear about these problems. I hope it didn’t spoil Christmas.

If you’re able to run an LED test and see some results, you have downloaded the examples and they compile and run. You’re using Python I assume?

A few questions:

  • What image are you using?
  • Starting with the motor test, are you getting any errors when you run the program?

#3

I am using the latest debian image off raspberrypi.org with the BrickPi python software installed.

When I run the motor test I don’t get any errors all It prints out to the console is running forward and running backwards.


#4

Ok, WastingLight, because you are using the latest debian image off raspberrypi.org, it doesnt have the comunication between the Raspberry Pi and the Brick Pi. You will want to download Or make the Modifications yourself. The instructions are provided


#5

@Ostrich can you please provide the Links were I can find the modifications I have to make ?


#6

Hey Morgs, a great place to start is our getting started page: http://www.dexterindustries.com/BrickPi/getting-started/

Go down to “modify your own image” here: http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/

And you’ll see the step-by-step of what you need to install to get the BrickPi talking with the Raspberry Pi.


#7

Had the same problem

http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/

There is the instuction to modify the original raspian image wheezy then it will work


#8

Okay thanks for all your help guys, sorry for the late response. I’ve just been out and bought a new SD card so I will be using one SD for my BrickPi and one for just coding and other stuff.


#9

Thanks guys I’ve just tested this with a new SD card And IT WORKED :D. I hope this post will help anyone else with this problem.


#10

Hey all,

So this week we’re starting to work on a single startup script that will take all of the changes that need to be made to an image to get it working, up and ready to work. We’ve had a LOT of folks have trouble getting these changes made (even if they realize where to start, it can be tricky getting it all to work). I just wanted everyone to know we see the confusion and problem, and we’re going to try to get something out there that’s a lot more simple to setup.