BrickPi Really doesn't work [Solved]


#1

I have just bought a BrickPi starter kit from Dexter.

I have assembled everything according to Dexter instructions - Raspberry Pi 3 and using their own SD with Raspbian OS

I am powering the BrickPi from mains.

I have connected EV3 motors to various ports on BrickPi and run the motor test routine.

The motors aren’t moving …

I can get through steps of BrickPiSetUp, BrickPiSetupSensors and BrickPi.MotorSpeed => But the motors just aren’t moving.

I’ve looked at the test and troubleshooting software, but it doesn’t have any provision for BrickPI

Can anyone help please ?


#2

Please also note, that I ordered the BrickPI from the US, but am using it in the UK.

I don’t know if this makes any difference - yes the power cable was inappropriate, but I just switched it for a UK cable.

is there anything else I should be doing or be aware of ?


#3

Ok, so I am guessing you recently bought the BrickPi so I am assuming you have the BrickPi3, the newest model. Just to make sure does your brickpi have a power switch on it? If so you have the BrickPi3. The Problem is then is that you are running the code for the BrickPi+, the old one, on the new BrickPi3. It gives no errors but does absolutely nothing. Go into the BrickPi3 folder (should be on your home folder or desktop) and follow this tutorial to get started.

https://www.dexterindustries.com/brickpi3-tutorials-documentation/


#4

Hi Kevin,
Yes I bought the Brickpi 3 and yes it has an on/off switch.

I have been following all the steps in the Dexter tutorials religiously. I got to the point of trying some scratch examples and nothing worked.

The troubleshooter mentioned in the tutorial doesn’t include Brickpi as an option on my own Brickpi.

In the absence of any other info I started trying to work my way thru’ some Python examples line by line (touch sensor example & motor example).

As you say, the python programs run but there’s no i/p or o/p to/from sensors/motors.

Since I couldn’t get any further with Dexter tutorials, I ran a python routine to check for Firmware and it found none. I then cloned firmware from GitHub only to find the version was only 1.something.

Then I used the software update tool on the Raspberry Pi. At that point I just had to give up… I just couldn’t take it anymore. I don’t know what version of the OS or firmware is running now.

Beyond the first few stages of assembling the BrickPi and installing the SD etc. The Dexter step by step tutorials just don’t weren’t helpful. I just don’t know what to do next.

Also, as an aside, another thing I noticed… I hooked the Brick Pi to a webcam thru" a USB port and managed to melt the battery pack that was powering the Brickpi… nowhere in any of the Dexter tutorial material was there any mention of this…it’s okay I’ve switched to main power now. But it’s only a matter of time before some kid badly hurts themselves with this. You really need to notify people of the risk.

Get Outlook for Androidhttps://aka.ms/ghei36


#5

Hi Kevin,

My apologies, it’s a very sleepless night.

I didn’t mean that you personally need to advise people of the risk of the battery pack frying… I really meant that Dexter should be doing this.

Margaret

Get Outlook for Androidhttps://aka.ms/ghei36


#6

It’s ok, I would like to here more about that battery stuff. Could you create another thread about that? I got a brickpi to and …

So have you been following the tutorial I gave you the link to? Because like I said the BrickPi+ code won’t work, so If your following the tutorial for the older brickpi it won’t work.

If you updated the software your fine, Also I’d update the firmware with the software updater. Just to make sure it’s all up to date.


#7

Okay so I have now taken apart the BrickPi3 box and taken a few photos (which I am attaching here). The RaspberryPI board does seem to be connected to the Raspberry Pi Board - so I really don’t understand why I am gettina a “BrickPI3 not connected” response on running the all-tests.sh

Does any one please have any ideas ?

?


#8

Hi Margaret,

Sorry that using the BrickPi3 hasn’t been straight-forward for you.

Try this program by running this command:

python /home/pi/Dexter/BrickPi3/Software/Python/Examples/Read_Info.py

You should see information about the BrickPi3 printed, including the voltage of all four power rails (battery, 9v, 5v, and 3.3v). Please post the output so I can see.

Regarding the batteries, what batteries were you using that melted the battery pack? Perhaps you had a defective cell, or perhaps the batteries were of very low quality. I’ve used it with batteries extensively, and I’ve never had the batteries get hot.


#9

You could follow this list of things to try, and report your findings.


#10

Hi Matt,
The batteries were Duracell - they’really pretty much top of the range here in the UK.

Thanks for the advice about checking voltages etc. I’ll try that first thing tomorrow.

I previously saw the note about looking at the LEDs flashing. They seemed to be okay this afternoon.

I’m in a really difficult spot right now. I’m organising a technical challenge at an international internal work conference. The conference will be the week after Easter. The challenge will involve embedding advanced AI and image processing in a mobile robot. I’ve been designing the challenge for over a month. In the process I progressed from EV3 language to RobotC and now to BrickPi 'cos EV3 brick just doesn’t have the processing power I need.

I’ve already ordered another 4 brickpi3 for the challenge teams. We were even going to make a donation of the BrickPi3 to a local school after the Challenge.

But now I’m really worried that I may have wasted a lot of time and money, because my confidence in BrickPi3 is just shattered…

I don’t have time left to spend trying to get the brickPi3 to work… I need to get working on integrating and cross-compiling the AI and image processing libraries onto the BrickPi3. I already have a PhD student working on running a deep neural net on a Raspberry Pi 3 and was hoping to port it to the BrickPi4. OMG this is turning into a nightmare !

When I ordered the current BrickPi3 from Dexter, it took 2 weeks to arrive. If this current BrickPi3 doesn’t work I’m stuffed… I will have 5 challenge teams and only 4 BrickPi3 (and at this point I don’t know how many of them will work). If I can get any of them to work, I’ll still be short at least one BrickPi3 ('cos I’ve pretty much given up on the present one). The UK distributor from whom I’ve bought the 4 BrickPi3 weren’t able to offer any significant help today (apparently, they just sell the BrickPi3 but receive NO training from Dexter - not exactly what I wanted to hear). The Canadian distributor was the same…

If I can get the 4 additional BrickPi3 I’ve ordered to work, is there anyway you can get me a replacement for the current (less than functional) BrickPi3 within a week… I’ve got to get all 5 kits and Mindstorms EV3 kits assembled & shipped to the conference venue in Turkey within the fortnight…


#11

P.s. I should also say that by buying the 4 BrickPi3 I’very cleared out the stock of the UK distributor - apparently it will take them 2 weeks to restock too… so no matter what way I look at this I’m truly stuffed unless (a) I can get the current BrickPi3 working (looking more unlikely by the hour…) or (b) you can courier a replacement BrickPi3 to me ASAP…Yes I’ll pay whatever, there’s just too much riding on this right now for it to fail.

Also, typo earlier, my PHD student is trying to port deep neural net to BrickPi3 (not 4).


#12

Sorry Matt, I should also say that I tried the troubleshooting tool. It came up with options for troubleshooting Grove Pi and 2 others, bit didn’the provide an option for BrickPi3.

Needless to say, I wasn’the impressed. That’s why I started using EV3-Firmware-Check routine yesterday only to figure out today that command was only for BrickPi (not BrickPi3) and ended up using the hardware/firmware check python routine today which revealed that the BrickPi3 wasn’the connected.

So there’should not much left that I haven’t tried at this point…


#13

If you can run that program I mentioned (the “Read_Info.py” python program), that will help me get a better idea what’s going on.

If that doesn’t work, try running the DI Update from the desktop. Once the GUI launches, run “Update Dexter Software”, and then select the BrickPi3 from the dropdown and click “Update Robot”.


#14

Hi Matt,

I’ll try the read info python programs you mentioned. But it’s nearly midnight here and I couldn’the risk taking the BrickPi3 home tonight (with the box disassembled) so I won’the be able to get the results to you for a few hours.

In the meantime, yesterday (when I thought the problem was firmware related) I used the software update tool (it did have a BrickPi tab) but it made no difference at all.

To avoid the time lag in our communications, is there anyway I could continue this discussion with a Dexter engineer in Europe in a few hours time. As I said, none of the national distributors I have contacted have been of any help. Bottom line, nobody seems to know anything. So they keep referring their questions to Dexter in the US.


#15

@m.hartnett I emailed you directly to set up a meeting. With the incredible success the BrickPi3 has been experiencing, I expect we’ll be able to get you going quickly.


#16

Hi Matt

I have run the program you suggested and get the response “BrickPi3 not connected”

All 3 LEDs are lighting

Red (Raspberry Pi board) all the time
Green (BrickPi3 board) all the time
Yellow (Raspberry Pi board) about once every second or two

The 4 other BrickPi3 starter packs have just arrived. But I am reluctant to spend any time assembling them until I can get the one on my desk working.

Margaret


#17

Hi Margaret,

I’m glad we were able to meet and get everything straightened out. When you finish the project, please share the awesomeness on the forums. If you have any more questions, feel free to ask.

Matt


#18