BrickPI3 : NXT Motor not recognized [Solved]

I just bought a BrickPi3 + Raspberry 3 + SDCard with system on your store. And I have a problem.
NXT Motors ( I dont try Sensor ) dont recognized.
I tried to install BrickPi3 software. But when I run this command, I Have :
pi@dex:~/Dexter/BrickPi3/Software/Python/Examples $ sudo python
Traceback (most recent call last):
File “”, line 22, in
BP = brickpi3.BrickPi3() # Create an instance of the BrickPi3 class. BP will be the BrickPi3 object.
File “/home/pi/Dexter/BrickPi3/Software/Python/Examples/”, line 275, in init
raise FirmwareVersionError(“BrickPi3 firmware needs to be version %s but is currently version %s” % (FIRMWARE_VERSION_REQUIRED, vfw))
brickpi3.FirmwareVersionError: BrickPi3 firmware needs to be version 1.3.x but is currently version 1.0.1
I suspect a firmware update.

Here serverals commands I tried :

The new BrickPi3 I ordered should not the last firmware?
It’s a firmware trouble?
Can I Do? ( I have no arduino or AVR Programmer for update Firmware… )

Thank you for yours replies.

Ok I just see a thread with the same Problem shame. I read first that [SOLVED] BrickPi Motors Are Not Running

Ok, The OS on the SD card deliver with the Starter Kit is outdated. I have install the last version and it’s work.
I close this thread.

This topic was automatically closed after 24 hours. New replies are no longer allowed.

Also, for anyone else wandering in here and looking at this post: the BrickPi motors will not run when only powered by a USB power supply. To run the motors you must power the BrickPi3 with batteries.