BrickPi3-RaspbianForRobots&VGA monitor issue


#1

I just installed the Raspbian for Robots image, “2017.06.21_Dexter_Industries_jessie.zip (1.5 GB)”. I followed the instruction found on https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/. When I power up the Raspberry Pi3, I’m not seeing anything on my VGA monitor that’s connected to my Pi. I’m using a HDMI-VGA adapter to connect to my VGA monitor. I’ve used this adaptor often with the regular Raspbian image with no issues.


#3

Hello @rmiller, a few tips for you on getting started:

  1. Make sure the monitor is plugged in before booting. If it’s not plugged in at boot, it won’t output to VGA.
  2. Make sure that you’re using a powerful USB power source. It needs to be 2A or greater.
  3. The SD Card may not have burned succesfully. We have a video here on what a successful bootup looks like. Does yours look the same?

#4

I watched your “what a successful bootup looks like” video. My 2 LEDs light up, as in the video, in the beginning of the startup process, but in a few seconds, the ACT LED goes out and doesn’t come back on or blink. Also, when I connect the Pi3 to a HDMI monitor, instead of using the HDMI-to-VGA adaptor for a VGA monitor, I see the startup process on the screen for a few seconds, then I get a disconnect signal on the screen.

I must have a bad “Raspbian for Robots” image, but I’ve downloaded, unzipped and installed “Raspbian for Robots” several times with the same results. Not sure what I’m doing wrong.
Any Ideas?
Robert


#5

How are you powering your setup?


#6

If I understand your question correctly, I’m using the CanaKit AC (5V, 2.5A) AC adaptor to power up the RaspberryPi3. I tried several installs of the Raspbian for Robots with the BrickPi3 board attached with no success. The last several installs have been with the BrickPi3 board removed from the Pi3, still with no success. Does the BrickPi3 board need to be connected to test the Raspbian for Robots image?

Once I downloaded the “2017.06.21_Dexter_Industries_jessie.img” image, I unzipped it and used Etcher to installed it on the micro SD card.


#7

Hi @rmiller,


##Possible Issues

There are a few things that might be the source of this problem:

  1. A bad micro SD Card - I’m referring to the actual flash drive - I think this can cause such random hiccups.

  2. That CanaKit AC adaptor - I’m not sure whether this adaptor is good or not and if it does have some voltage regulation issues, regardless of its rated amperage, that’s going to make the Raspberry Pi crash.

  3. I hope you’ve used a dedicated HDMI - VGA converter (which should have a separated PSU), as converting these 2 signals between them requires some kind of processing - don’t forget these are analog and digital signals. The HDMI is known for giving around 50mA on it’s line, while some converters (that don’t have a separate PSU) can draw hundreds of mA. The consequences for a Raspberry Pi can be bad.


Suggestions

What I’m most worried about is the Raspberry Pi.
I’m quoting from this site: https://www.raspberrypi.org/forums/viewtopic.php?p=269212

That said though, unpowered converters are still a risky gray area, because the pi has a diode in place that can easily burn out if too much power is being pulled through the HDMI port - you would be well advised to get a HDMI>VGA converter with it’s own power supply

Do you have a spare Raspberry Pi to test with?
If you do have one for testing, also do a reflash of the micro SD Card as it could have become corrupt already.


Another thing to do would be to change the power supply with another AC adaptor and see if there’s an improvement.

Checking the Raspberry Pi with a new micro SD Card could also remove some of the suspicions.


Conclusion

Please let us know what you’ve decided to start with and we’ll also be here for more assistance.


Thank you!


#8

I still can’t get “Raspbian for Robots” image to run on my RaspberryPi3. I thought, at first, because I could not get my HDMI-to-VGA adaptor to work, it was an issue with the adaptor; but after connecting it directly to a HDMI TV Monitor, I feel it must be an issue with the “Raspbian for Robots” image I downloaded and installed or with Etcher’s Flash process.

My RPi3 and HDMI-to-VGA adaptor is working great when I use the latest standard “raspbian” image using NOOBS.

The steps I took to install “Raspbian for Robots” are as follows:

  1. I went to the instructions at “Install Raspbian for Robots on an SD Card for the Raspberry Pi” https://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/
  2. Click on “Using a PC”.
  3. Click on the link, “Sourceforge”, when to “File” and click and downloaded the image, “Download 2017.06.21_Dexter_Industries_jessie.zip (1.5 GB)”.
  4. I unzipped it using the “Extract All” option on my Windows 10 laptop.
  5. I downloaded Etcher, version “Etcher-1.0.0-win32-x64.exe”. I followed the instructions to select my “Raspbian for Robots” image, select my drive and start the Flash process. All went as it should have according to instructions.
  6. I connected my HDMI-to-VGA adaptor to the Pi3 and then to my VGA monitor. Place the MicroSD card with image in my RaspberryPi3 and power it up. On the Pi3 the PWR LED lights as it should and stays on. The ACT LED blinks for a few seconds and goes off and stays off; no blinking as it should.
    Note:
  7. To check to see if the HDMI-to-VGA adaptor is the problem, I connected the Pi3 directly to my HDMI TV, instead of using my stand-alone VGA monitor (with the HDMI-to-VGA adaptor). When I power up, I get, for a few seconds, the startup process on the screen. Then after a few seconds, my TV screen gives me a disconnect message and the blinking ACT LED on the Pi3 goes out and stays out. Because I’m connected directly from the Pi3 to a HDMI TV, the HDMI-to-VGA adaptor can’t be the issue.
  8. To check to see if my MicroSD card is corrupted or Pi3 damaged, I used “SDFormatter” to reformat the microSD card and used “NOOBS_v2_4_2” to install the latest standard version of raspbian (not raspbian for robots). During and after the install, I use the HDMI-to-VGA adaptor, and raspbian and the VGA monitor is working great. So, with this, I have ruled out the microSD card being corrupted and the Pi3 being damaged. I’m at a lost to why the “raspbian for robots” image is not working.
  9. To check to see if my AC adaptor is the problem, I used it during the successful install and use of the standard raspbian image, all worked as it should.

Two questions:

  1. Have I left out a step to correctly install “raspbian for robots”?
  2. Is there a way I can install “raspbian for robots” without using Etcher?

Thank you,
Robert


#9

Hi @rmiller,

Alright, so it seems like your Raspberry Pi 3 isn’t damaged and it works with another distro.


Here’s what I would next:

  1. Try burning the image with Win32DiskImager instead.
    Head over to Advanced: Using a PC and Win32 Disk Imager section in our tutorial on how to install Raspbian For Robots and use the instructions found there.

  2. Use an older image (link here) we have on sourceforge.

I’m waiting to see what happens on your side as my Raspberry Pi 3 works with the latest image and yours doesn’t seem to.


Thank you!


#10

Okay, following your latest instructions to use Wind32DiskImager to install the older image of Raspbian for Robots, “2017.04.02_Dexter_Industries_jessie.img” instead of “2017.06.21_Dexter_Industries_jessie.img”, I have some success. Connecting directly to an HDMI TV monitor, I can see the Pi’s desktop. I still could not use my HDMI-to-VGA adaptor with this image of Raspbian for Robots.

Also, I was able to connect with PuTTY and access my Pi3 files via Samba. This is how my blind and visually impaired students have been accessing the Pi. This connectivity approach greatly reduces the need to have a monitor connected to the Pi.

I tried to update the older image, “2017.04.02_Dexter_Industries_jessie.img” by clicking on the Update icon on the Pi3’s desktop. But after the lengthy update process, I was back to the original issue of the Pi3 not completing its bootup process and losing its connection to the HDMI monitor. I had to go back and reinstall the older image, “2017.04.02_Dexter_Industries_jessie.img”.

As it stands, I should be good with this older image, right? Thanks for helping me get this up and running.

Also, I’m having issues connecting the Pi3 with my Windows 10 computer using VNC Viewer. I’m sure this is me not doing the setup procedure correctly. Can you give me the correct steps or direct me to the webpage?

Thanks again, and if you have ideas about why the latest image of “Raspbian for Robots” is not working for my Pi3 and want me to do some test, let me know.

Robert


#11

Hi @rmiller,

It seems like you aren’t the only guy having this issue.
I think we may be facing a bug somewhere and something tells me is about the Raspberry Pi's kernel.


I’ll test the latest image of Raspbian For Robots and come back with an answer to you.

In the meantime, you’re good to go with the older image - for now.


Thank you!


#12

Thanks for helping and being so quick with your replies!

Robert