BrickPiRx Error : -2


#1

Hi there. I have the following setup:

  • BrickPi (new)
  • RaspberryPi Model B rev1.1
  • 12vdc 2A power supply, connected to the BrickPi power input connector.
  • Latest Raspbian image: 2015.11.09_Dexter_Industries_wheezy.zip on an 8Gb SD card
  • Ethernet, keyboard, mouse, HDMI monitor
  • Lego Mindstorms (not EVE) motor and touch sensor
  • I have enabled Debug = 1 in BrickPi.py

The Pi boots up ok, I can connect to the internet and view web pages.
The BrickPi seems ok: I can run BrickPy_Python/Sensor_Examples/LED.py and LED_PWM.py (blue lights flash).

However, when I run any of the other sensor tests (eg LEGO-Touch_Sensor_Test.py) I get BrickPiRx Error : -2 repeatedly.

This is very frustrating: are there any diagnostic tests I can run to help narrow down the cause of the error?

Thank you


#2

Hi Roi, sorry about the frustration with the BrickPi. Three quick questions for you:

1). Have you tried to enable the serial lines: http://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/
2). Have you run any of the motor examples?
3). Have you modified the example programs at all?

John


#3

Also, it is possible to run the hardware test and post the output log here?


#4

Thanks John, enabling the the serial lines did the trick.

Running the hardware test produced the following output:

Button reads: 1021
Running Forward
BrickPiRx Error : -2
BrickPiRx Error : -5
Button reads: 1023
Running Forward
Button reads: 1023
Running Forward
Button reads: 1020
Running Forward
Button reads: 1020
Running Forward

etc

The errors (-2 and -5) recurred a few times, but the motor runs fine.

Running the LEGO-Motor test, the Touch Sensor test and the Ultrasonic test all ran successfully.

Thanks for your help.


#5

Phew, glad that worked. Yeah, unfortunately on the new image when i published it, I left the serial lines disabled by default. I will develop a fix for this and the new default will be with the serial lines on. Thanks for letting me know that worked!