Can not connect to the internet


#1

I just got my BrickPi in the mail and after a bit of work i was able to connect my brick pi to my windows 8 pc by VNC and the Ethernet cable. Whenever i try to connect to the internet by plugging in the Monoprice USB 2.0 wireless 802.IIN, the vnc disconects and I can’t Connect to the internet. I also can’t figure out how to use my computer to bring wifi to my brick pi.


#2

Sometimes plugging in a USB device resets the Raspberry Pi. If you startup with the WiFi device plugged in, are you able to login via ethernet and VNC, and then setup your wifi device for operation?


#3

Ok, this time I pluged it in before like you said and when that happened, i was able to connect to the raspberry pi through vnc. However, when I got to wpa_gui to connect to the wifi, it says, same as before,

Could not get status from wpa_supplicant

as the status. I also went to /etc/wpa_supplicant and tried to open the config file, but I got this error message,

Failed to open file '/etc/wpa_supplicant/wpa_supplicant/wpa_supplicant.conf': Permission denied

I tired to use leafpad to open it.


#4

Ostrich,
How about modifying your “interfaces” file:

in the terminal, can you type the following:
sudo nano /etc/network/interfaces
That should pull up your interfaces file.
In interfaces, can you change the details to your network configuration (the IP numbers, and your SSID and password), and then reboot.

If you can make these changes, and still can’t connect to the internet over your wifi network, can you run, (again in the command line)
ifconfig
and post a screenshot of what that command returns?


#5

Well, I got it to work sort of… What I did was I made a new SD card with the modified OS and I plugged it into my hdmi tv and was able to connect to the wifi… I’m going to try to update the pi because the pi still will not able to use the wifi… even with this sudo nano /etc/network/interfaces I already had found that and i hadn’t worked. My theory is when I set up the ip address for the Pi, it somehow interfered with the internet connection, but I still cannot connect by wifi.