Can not use ttyAMA0


#1

Just installed latest driver and dependencies. However when I run the Touch sensor test example it raises the following error:

Traceback (most recent call last):
  File "./LEGO-Touch_Sensor_Test.py", line 18, in <module>
    BrickPiSetup()  # setup the serial port for communication
  File "build/bdist.linux-armv7l/egg/BrickPi.py", line 665, in BrickPiSetup
  File "/usr/local/lib/python2.7/dist-packages/serial/serialposix.py", line 294, in open
    raise SerialException(msg.errno, "could not open port %s: %s" % (self._port, msg))
serial.serialutil.SerialException: [Errno 2] could not open port /dev/ttyAMA0: [Errno 2] No such file or directory: '/dev/ttyAMA0'


#2

Did you enable serial on your custom version of Raspbian?


#3

Yes, everything was installed correctly and configured.
After some testing I found out that it works when one change its default port to ttyS1. But I can not remeber in which file it was defined.
(And sorry I forgot to mention I use a Banana Pro).

Thanks for the help anyway.
Greetings, Pixdigit.


#4

Makes sense. Glad it worked out!