Can't connect Computer to GoPiGo3

I have a Raspberry pi 3 and GoPiGo kit that I just assembled. The Raspbian for Robotics microSD card is in. The power is on and LED lights are looking good. I have my ethernet cable from my computer to the GoPiGo working (both have lights on).

I am using Linux (xubuntu). When I try loading http://dex.local, I get server not found. I tried to ping dex.local from the command line. All the tutorials/instructions are for Mac or PC. Is there anything that I can do?

Help and suggestions are appreciated.


Hi @nick.denis.1983,

In order to connect to a device that’s on the local network, you also need to follow this tutorial (go to the Linux section).

Follow the tutorial and then try again connecting to dex.local.

Please tell us how it went.

Thank you!

I have the same symptoms and but I am using a Mac OS X. The “ping” command returns an error; ping: cannot resolve dex.local: Unknown host
I’ve been watching lots of tutorials without any progress, and I’m totally confused. My parents don’t really understand either.
Kindly help.


Thanks for the answer RobertLucian. I had found that tutorial previously and had already followed those steps as well.
I should also add that the wifi dongle is in, however my computer does not read any GoPiGo networks, nor do I see any lights (blue nor green) as shown in this photo for the “connect to your robot” section (, both with or without the ethernet cable attached.

Any other thoughts or ideas?

Hi @RobertLucian,

I had found that tutorial previously and had already followed those steps as well.
I should also add that the wifi dongle is in, however my computer does not read any GoPiGo networks, nor do I see any lights (blue nor green) as shown in this photo for the “connect to your robot” section (, both with or without the ethernet cable attached.

Any other thoughts or ideas?

Hi @nick.denis.1983,

You’ve been following the tutorial for DexterOS, which is a totally different product we have.
Here’s a link to the tutorial that you’re interested in.

Again, in order to be able to go to dex.local on your personal computer, you have 2 choices:

  1. Connect your RaspberryPi to your laptop via an Ethernet cable. You need to have Bonjour installed (this holds up for MacOS and for Windows - @nonohoriuchi, check if you have it installed).

  2. Connect to your RaspberryPi via the same WiFi network. You’ll need to setup the RaspberryPi to connect to the same WiFi network as your laptop.
    For doing this, you can either use the first numbered-point in order to connect to the RaspberryPi and then set up the WiFi or you can connect the RaspberryPi with an HDMI to an HDMI-capable display and then set up the WiFi manually.


You need to get both the Raspberry Pi and the laptop on the same WiFi network (which has to be your home network). Then you can go to dex.local.

Thank you!

1 Like

I am slightly confused. I am using a GoPiGo3, and according to my dad, you don’t really need to install anything.
Clarifying my problem just in case, the WiFi was fine, there was the GoPiGo and ethernet internet available, but when I input the ping command as in the tutorial, it just doesn’t work.


we have three different approaches and each answers different needs.


  • will have its own access point called GoPiGo
  • Does not let you access the internet
  • Does not let you SSH into the Pi
  • You can code with Bloxter or Python


  • Will have its own access point called Dex
  • Does not let you access the Internet
  • You can SSH into the Pi
  • You can access the Pi desktop through VNC viewer (that you need to install) or through browser by going to http://dex.local

Raspbian for Robots

  • Does NOT have an access point
  • You need to use an ethernet cable in order to set the Pi with your wifi information (and you may need to install tools on your computer for this)
  • Allows you to connect the Pi to your wifi system and therefore the Internet
  • You can access the pi Desktop through VNC VIewer or by browser (http://dex.local)

So if you have Raspbian for Robots, it’s possible you have to install some tools in order to resolve network issues.


1 Like


I’m just starting to experiment with GPG3 and got troubles having the access point mode work.

The configuration :

  • RPi3
  • GoPiGo3
  • DexterOS image 1.0.3-Final
  • using RPi internal Wifi (i.e. no Wifi dongle)

I have no problem ssh-ing to the RPi from my Linux laptop once booted, and have applied the various steps for updating the system (firmware included) without any problem. I can also work in VNC mode by pointing the laptop browser to http://dex.local. So far, so good, apart that the demos are not working 100% as expected, but this is not the point.

My concern is that I can’t see how to have the GPG work in access point mode to be able to experiment with Bloxter. It must be noted that at no time the antenna LED lights up during the boot sequence. Is this supposed to work only with the Wifi dongle (i.e. not supporting the RPi embedded Wifi) ?

Thanks in advance for any clue.

Best regards


Hi @EricPascual,

I’m confused as to what image you’re using.

So, with the DexterOS image, you don’t have access to an SSH terminal and you can’t login with the regular credentials.
In order to connect to dex.local, you must have the Raspbian For Robots image, which is an entirely different OS.

My instinct tells me you are using Raspbian For Robots. With Raspbian For Robots you don’t have access to Bloxter as it’s a different product. And even more, the antenna WiFi LED turns on only on DexterOS and not on Raspbian For Robots.

If would be great if you can tell us where you felt lost in understanding our products. Your feedback can help us understand where we need to improve ourselves.

Thank you!

Hi Robert,

Many thanks for your quick reply which makes a lot of sense to me. But the file I’ve burned on the SD is named It looks like it is the Raspbian image although the name tells a different story. I’ll give it another try after re-downloading it again and keep you informed.

Anyway, my first feeling about the GPG3 is quite positive WRT the hardware : the assembly went fine (despite some minor adjustments of the instructions about the right way to bolt the motors and their supports). The robot gives a good feeling of sturdiness.

The first experiments with the gopigo3 Python library gave positive results too… after a ‘git pull’ of the version included in the SD image : I initially got an import error of a mock_xxx module which was missing in the original version while playing with one of the examples, and the test application behave strangely (despite the printed message, the motors turned in one direction only). Scratch tests were not so fine, some of the actions selectable in the “broadcast” block having no effect. But since I played with Scratch before updating the gopigo3 Python library, maybe this is related. I’ll give it another try as soon as possible. It looks like the image I have used was not 100% production ready : the git status before doing the pull reported not committed local changes, and BTW it’s surprising having a library installed as a dev project.

Anyway I keep optimistic about the final verdict, and have the feeling the GPG3 could become one of the tools used in my robotics association for kids initiation to technology.

Best regards


Hi @EricPascual,

I initially got an import error of a mock_xxx module which was missing

This is because the DI_Sensors repo isn’t in the filesystem. If you do this manually, then yes, you’ll have to install all dependencies. For instance, on Raspbian For Robots, you already have this repo installed.

By the way, when you get yourself the Raspbian For Robots image, please update both the software and the firmware of it. We’ve been doing lots of changes in the last weeks.

Thank you!

Hi @RobertLucian

I did it as the first step after booting the RPi, as per instructions of the Web site.

I could notice it based on the Git change log. This is the sign of an active project :slight_smile:

Best regards

1 Like

Hi @RobertLucian, I found I don’t need Bonjour, and I could successfully program my robot in Bloxter, but I want to code in Scratch. Can I do that? If so, how?

Hello @nonohoriuchi,
for Scratch you will need either Cinch or Raspbian for Robots. It is not supported in DexterOS/Bloxter.


1 Like

A gopigo3 with the DexterOS SDcard that came in the box shows its base station. Both an older Lenovo laptop with older Windows, and a Dell desktop with a WiFi card see and connect to the base station, and you can make an LED blink from the Python programming web page. An image of Raspbian for Robots burned into a spare SDcard boots the robot. An ethernet cable between the laptop and the robot has the white light on and the green light periodically flashing, at both ends of the CAT6 cable. But nothing happens. The Windows machine is set to obtain an IP address automatically. Wireshark shows periodic DHCP and DHCPv6 requests. but it shows no traffic at all from the robot. With a cable from the robot to a 5 port hub, and from the hub to the Windows machine, green LEDs flash but still nothing happens and no robot traffic visible in Wireshark. With a third cable from the hub to a Linux machine, Wireshark shows tons of traffic when Filezilla on Windows fetches from Linux. This location is far from civilization and the locals think it would take weeks to get an HDMI to DVI-D cable. Do you have any suggestions of other things I might try?

The USB drive in the robot, viewed under Windows, has multiple files of the messages/syslog variety. I see no obvious problem in it setting up the Ethernet. I couldn’t find a way to attach a log to the previous posting, and the files are several hundred lines long. :frowning:

Once you move to Raspbian for Robots, a lot of things change. The blue antenna LED will not turn on, for example, and you will no longer have access to Bloxter and Jupyter (where you code with Python)

does the Windows machine have Bonjour installed? If so, you can start a browser and type in dex.local to be taken into a VNC session.
Or you can install Putty and get a shell session going.
My personal preference is to use VNC Viewer

Have you tried any of those?

Are you sure your ethernet cable isn’t bad?

Do the led’s on the raspberry pi look normal when it’s booting? The red led should be lit solid, and the green led should be going on and off while booting. If these don’t look normal you might need to re-flash your SD card (or maybe the SD card is bad).

When I’m making a new SD card for a headless raspberry pi, I create a file named wpa_supplicant.conf in the boot partition of the SD card with the following content:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

You will need to put the SSID and PassPhrase from your WIFI setup in the above file and change the country code if you are not in the US.

Just put the SD card in your GoPiGo, boot it up, and you should be able to connect via WIFI without any further setup.

If you are using a plain Raspbian image instead of Raspbian For Robots, you will also need to put an empty file named ssh in the boot partion of the SD card to enable ssh (it’s enabled already in the Raspbian For Robots image).


1 Like