Can't get the BrickPi to respond to Lego Motor and sensor


#1

I think I setup everything correctly. The last step returns “Connected to Scratch successfully”. Therefore I assume all the proceeding steps are correct.
But when I try to run the examples (drive motor or touch sensor) the program/BrickPi does not recognize the devices. Is there some sort of test to run that checks out the BrickPi without Lego devices connected?


#2

Hey szl, we’re actually working to develop this. Something that just checks whether everything is correctly installed and the hardware is working. In the meantime . . . what version of the image are you using? Did you get it or download it from us or somewhere else?


#3

I’m having the same problem with scratch. No problems getting python tests to work but motors and sensors don’t respond in scratch. Were you able to fix yours? If so how?


#4

Just got it to work. Just realized that scratchpy had timed out. After I re-activated it in LX terminal scratch worked.


#5

Sorry about the delay in responding
The latest that I have used is 2014.03.13_DI_USB-EXPERIMENTAL same results. In addition, can’t get the wifi to work with this version of BrickPI (works with Wesley). Is there a dummy type setup so that I can checkout my hardware and then I will be able to concentrate on the software development. Would like to get an idiot’s setup for headless operation of your simpleBot robot.


#6

Hey szl,
There’s a much better option for scratch out now, just announced in the latest MagPi: http://www.themagpi.com/issue/issue-23/

I think it’s much easier to use now. It performs a lot better technically than the previous version we had.

WIFI: can you give a little more detail about what’s not working? What have you tried and what happens?


#7

Have not yet read the article. Thanks so much for pointing me in the right direction. Using the WiFi config wpa_gui program I am now able to get on to the internet via my WiFi connection. Now to read the article and then on to my next problem.
Thanks again