Cinch OS not brodcasting wifi

pending
cinch

#1

Hi,
I just downloaded the cinch OS(latest) and got it into a SD card and loaded it in the GoPiGo , I was able to connect it to a HDMI display and see the OS with the desktop.

But the OS is not displaying any dex as an wifi access point.

FYI…I rebooted the system twice.
I have attached the pictures along with this also.

What could be wrong?

Appreciate the help.

cannot upload more than 1 picture. So here is one of them


#2


#3


#4

Hello @forum

Do you happen to know what type of Raspberry Pi is in there? Is it a Pi2, a Pi3, or a Pi3B+ ?

ETA: answering myself, I can see it’s not a Pi 2. It looks like a Pi3. So it should have worked.

I will let @RobertLucian take it from here as I’m not that familiar with Cinch.

Cleo


#5

Hi @cleoqc, Thanks it is Raspberry PI 3 AFAIK, I got it about 3 months from your store. We want to use it in school as well as use python/go to build the solution.

Appreciate the help.

Thanks


#6

I loaded the latest Cinch image (2018.01.29-BETA_Dexter_Industries_CINCH.img) on a PI3 and it works. I can connect to dex wifi access point and connect using ssh, web browser, or vnc at 10.10.10.10 or dex.local.

This image would not boot on a PI3B+ - I updated the software on a PI3 and it still would not boot on the PI3B+ (red led on PI blinking in a constant pattern).

Followed advice from this thread: https://raspberrypi.stackexchange.com/questions/81725/raspbian-8-on-raspberry-pi-3-b and now it boots on the PI3B+ and I can connect to the dex access point and connect with ssh, browser, or vnc.

This is an older image based on Jessie.

The newest Raspbian For Robots image is based on Stretch, but as reported by @RobertLucian in this thread: https://forum.dexterindustries.com/t/cinch-operating-system/5387 the scripts to convert a Raspbian For Robots image into Cinch and vice-versa don’t work with Stretch.

I was able to use the latest R4R image (2018.06.27_Raspbian_For_Robots_by_Dexter_Industries-stretch.img) and get it working as a dex access point and connect to it at 10.10.10.10 or dex.local by following the instructions here: https://www.raspberrypi.org/documentation/configuration/wireless/access-point.md.

This is what I added at the end of /etc/dhcpcd.conf
(set access point address to 10.10.10.10):

interface wlan0
static ip_address=10.10.10.10/24
nohook wpa_supplicant

Contents of /etc/dnsmasq.conf
(provide ip addresses in range 10.10.10.2 to 10.10.10.9):

interface=wlan0 # Use the require wireless interface - usually wlan0
dhcp-range=10.10.10.2,10.10.10.9,255.255.255.0,24h

Contents of /etc/hostapd/hostapd.conf
(set access point ssid to dex and passphrase to robots1234):

interface=wlan0
driver=nl80211
ssid=dex
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=robots1234
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

Note: This setup differs from Cinch in that it provides a secure access point (I tried but could not get this working with the Cinch setup).

Stop when you get to the instructions titled Using the Raspberry Pi as an access point to share an internet connection (bridge).

-Kevin


#7

Hi @forum and @kev.r,

I’m gonna test it both ways: first one just by using the Cinch image and the 2nd one by converting a R4R image to Cinch.

I don’t have much to suggest now and I’ll be back with an answer as soon as I have something.

Thank you!


#8

Thanks will wait for your output,