Communication Problems


#1

Hello,

I have a similar problem. My motors are not responding. I do not have Dexter Industries version of the wheezy.

The BrickPi is run in the Desktop mode with micro-usb power going to the Pi, and the BrickPi being powered by a fresh new 9V battery. There were no error when setting up the github repos, nor where there any errors during the installation of the BrickPi Module.

But after having eliminated all the issues, I ran the BrickPi.py in debug mode. And this is the error (below) that was written out at the end of the LEGO-Motor_Test.py program.

I hope I don’t have a bad unit! Please help me resolve this issue.

Thanks,
Andy

Traceback (most recent call last):
File “LEGO-Motor_Test.py”, line 33, in <module>
BrickPiUpdateValues() # Ask BrickPi to update values for sensors/motors
File “/usr/local/lib/python2.7/dist-packages/BrickPi-0.0.0-py2.7.egg/BrickPi.py”, line 413, in BrickPiUpdateValues
BrickPiTx(BrickPi.Address[i], tx_bytes, Array)
File “/usr/local/lib/python2.7/dist-packages/BrickPi-0.0.0-py2.7.egg/BrickPi.py”, line 497, in BrickPiTx
ser.write(tx_buffer)
File “/usr/local/lib/python2.7/dist-packages/pyserial-2.7-py2.7.egg/serial/serialposix.py”, line 518, in write
raise SerialException(‘write failed: %s’ % (v,))
serial.serialutil.SerialException: write failed: [Errno 5] Input/output error


#2

Hey Andy, I moved the conversation. it looks like the serial communications failed, and not the motor port of the BrickPi.

You mentioned that you’re not using the DI image.

Best,

John


#3

Thanks! Sorry, I posted to the wrong thread.
To your questions - No, everything went smooth when I followed the instructions on setting up github, and also when I installed the BrickPi python module globally.

Also, I took the original test program, and played around with motors C and D instead of A and B. But the results were no different.

Let me reflash the sd card with your version of wheezy and see if that works.

Quick question: the Raspbian image that I have is dated 2014-02-07. Is your wheezy dated the same? If not, could this be the problem?

thanks
Andy


#4

Hmm. Ok, just to cofim, you’re NOT using the Dexter Industries image, correct? Because if you’re not, you do need to make some changes to the image. We outline those here: http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/ under “modify your own image”. There’s another script referenced in there that you need to run to make a few changes to the Raspberry Pi, like setting up I2C and serial comms.

Anyways, if you use the DI image, it should have everything pretty well setup and ready to roll. So give it a shot and let us know!


#5

It worked! I re-flashed my card with the DI wheezy and the motor test worked!

You’re right! I forgot to add the DI pre-installed card when i ordered the BrickPi and decided to set it up myself.
But after reading through the link, it was obvious that I was missing files.
Not sure where I went wrong.

Anyways, let me test all the other sensors.

Thanks much!
Andy