Connect with Ethernet cable


#1

Stuck at step 1
With the power off, remove the SD card from the Raspberry Pi.
Open this in your computer, and open the file “cmdline.txt”.

Where is this file located :cmdline.txt. On the SD card?.
I was able to create the image and dowmload to the SD card, But cannot read it again my Windows 7 laptop wants to format it .


#2

The file “cmdline.txt” is located in the top directory of the SD card. Maybe your SD card was corrupted while burning the BrickPi image to the card?


#3

I tried to read the SD card on another laptop and it worked. Now to the ethernet setup. I get a address for my laptop through ipconfig 169.254.154.169. I modify the cmdline.txt file to include the part at the end IP=169.254.154.170.

With that light are on solidly on the Rpi red,pw, green fdx, lnk and yellow 10M. Nothing blinking although. Laptop LED 's are dark. What now ?


#4

Are you trying to connect the Ethernet cable directly between your laptop and RPi? Unless you are using a cross-over cable (specifically for this application), it almost certainly won’t work. Even with a cross-over Ethernet cable, the laptop would need to be hosting a network (be a DHCP server) on it’s Ethernet port.

I think what you want to do is connect the laptop to a router (using either Ethernet or WiFi), and then connect the RPi to the router (using Ethernet).


#5

I’ve got my RPi and laptop connected directly with a normal Ethernet cable. I managed to get that far, at the very least…

I do have a monitor currently on the HDMI port so that I can see if it’s booting or not. I’m having problems booting with the BrickPi installed, but not without it.

I would suggest that, as a first step. Can you boot just the RPi, and then SSH in ?


#6

I hooked the Pi to a HDMI monitor and checked that everything boots and the SSH is running . All seems fine. I think the problem is probably that it does not get a IP address assigned via the DHCP server. Now why did I enter the static ip in the cmdline.txt in the first place ?.

I will also try the router approach now.


#7

Editing cmdline.txt from within the raspberry I noticed that it was not a continuous line but the ip=… was on a separate line. Fixed that and was able to communicate. Off to the next step.I used Putty to login with Pi, raspberry.
Off to the next step.


#8

cviehoff. Good to know, thanks for updating us.


#9

I am also having difficulty getting this option to work on my Pi. The instructions clearly state:

“Plug one end of your ethernet cable into your Raspberry Pi, and the other into your computer ethernet card.”

I’ve followed all the instructions, given my laptop a 192.168. ip and given the pi one as well. I cannot connect through either SSH or VNC.

Speaking of which, is SSH enabled by default?


#10

mstreet:

“Plug one end of your ethernet cable into your Raspberry Pi, and the other into your computer ethernet card.”

That’s correct. And this works with a standard Ethernet cord, no need for a crossover cord or anything. I originally used a simple cord I picked up at Best Buy.

Did you use the BrickPi image we have for download?
What are the lights next to the Ethernet port doing after the RPi is plugged in?
I hate to ask this, but is your RPi powered? How?

SSH and VNC are enabled by default on the BrickPi image.


#11

matallen, that’s actually incorrect. This works fine with a standard Ethernet cable and it certainly doesn’t need a cross-over cable.


#12

Just another general comment to everyone following this thread: the most likely problem is putting a new line in the cmdline.txt ; if you add a line, it will not work.


#13

Hi,

Thanks for the replies. It’s very strange though, I can only see them in email, not in this forum at all. I’ve tried viewing it logged in and out, different browser, etc.

It seems either you have some aggressive caching going on, or perhaps posts from ‘Administrator’ cannot be seen by us mere mortals.

Actually, scratch that because I can’t see my own post either. So it must be some caching on the server end. Anyway, I’ve included your replies here just so others can see it.

Administrator wrote:

mstreet:

“Plug one end of your ethernet cable into your Raspberry Pi, and the other into your computer ethernet card.”

That’s correct. And this works with a standard Ethernet cord, no need for a crossover cord or anything. I originally used a simple cord I picked up at Best Buy.

Did you use the BrickPi image we have for download?
What are the lights next to the Ethernet port doing after the RPi is plugged in?
I hate to ask this, but is your RPi powered? How?

SSH and VNC are enabled by default on the BrickPi image.

Post Link: http://www.dexterindustries.com/forum/?topic=connect-with-ethernet-cable/#post-444

To answer your questions, yes, I’m using the BrickPi image. The lights are flashing and it looks like it normally would when I boot it.

I’ve gotten around the issue by plugging my raspi into my router and connecting through my laptop, which is on the same network but through wifi. Unfortunately, I cannot get my wifi dongle to work with your BrickPi image but at least wired works. My wifi dongle (called WiPi from newark or adafruit, can’t recall), works from a regular wheezy image. I may just end up modifying that if I can’t get wifi working. If I still have trouble, I’ll post a new thread for that.


#14

I guess I’m used to using older Ethernet hardware that didn’t allow it (at least that’s what I’ve heard, so I never tried). I didn’t know you could connect devices directly like that.


#15

The only way I have to get to see new posts (including my own) is by logging off and logging in again.
I hope it works for you!


#16

Hey folks, sorry about the login/logout problem. This has been pointed out a few times and I’m struggling to get it corrected. I think it might be at this point, cross my fingers.