Connecting to Pi


#1

I’m sorta new to this so sorry if I’m a noob.

I’ve followed all your instructions to connect to the pi by vnc viewer but I always get the error message:

connect: Connection timed out (10060)

#2

Hey Ostrich,
Welcome to the world of Raspberry Pi then!

So you’re connecting to the Raspberry Pi via VNC, correct?

Are you trying to connect via WIFI or via ethernet?

Can you paste the changes you made in cmdline.txt? Should look something like this:
like:dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait ip=169.253.181.61

Also, can you verify there are no returns in the text file (no new lines)?

Do you have any other way of getting on the Raspberry Pi other than the ethernet route?


#3

After following your video, I tried to use this code to connect by Ethernet to VNC. There are no returns. And as well, like I have said before (in an other forum) my wifi still does not work.

dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
 ip=169.254.0.61

However at the moment I’m using a second monitor which is kinda heavy so I’d like to be able to use it on my laptop.


#4

And as well when I have been trying to install things, I have around 2 gigs of space when my sd card is 8 gigabytes and I looked at the partitions, and it more than 5 gigabytes are not partitioned.


#5

Wow, we’re packing a lot into this one single post.

First, you can expand your Dexter Industries SD Card by running the command

sudo raspi-config
And expanding the rootfs to use all available space on the SD Card. This will make your 8GB accessible.

Ethernet: Ok, you say there are no returns in the file, but it looks like you’ve got a new line in there before “ip=”. Also, another area of concern we’ve seen: if you use the microsoft text editor, it can cause problems. Can you use Wordpad and not Notepad to look at the file and make sure there are no extra characters?

WiFi: If youc an access your Pi with a monitor and keyboard, what do you get when you run “ifconfig”? Does your wlan0 show up? Do you have an IP address for it and do you have any traffic on tx/rx?


#6

Sorry to get back to late. At the moment I am using a monitor with my Pi. However on bootup, the wlan0 gets an error, can not start or something like that.


#7

Hey Ostrich, good to hear you have a way of getting to the BrickPi. I’d still like to see if we can get the network to work for you; if you have answers to the above questions, we might be able to help you troubleshoot more and get rolling.


#8

Ok well, I checked with WordPad and notepad ++ there aren’t any returns. When I boot the Raspberry Pi and it tries to start the wlan0 it gets this error:

Configuring network interfaces...wpa_suppliacnt: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Cannot find device "wlan0"
Failed to brick up wlan0.
done

I am using a new sd card because I am using my other sd card for my science fair project with the BrickPi!


#9

Also when I run ifconfig, only etho0 and lo show up


#10

Also when I run ifconfig, only etho0 and lo show u

I think that means that the WiFi dongle either isn’t being recognized or isn’t working. It’s probably not being recognized as such.

Are you using the Dexter Industries wifi dongle? If not, can you tell us more about the dongle you’re using on the raspberry Pi?


#11

I am using the Dexter Industries one


#12

Ok, wow. I rebooted with the dongle in. I got new errors on start up on but when i run ifconfig, wlan0 shows up.

Here are the 3 Errors

[...]Waiting for /dev to be fully populated...[   11.624720] mmcblk0: error -110 transferring data, sector 753608, nr 72, cmd response 0x900, card status 0x80000b00
[   11.631575] mmcblk0: retrying using single block read
[   22.556540] mmcblk0: error -110 transferring data, sector 1552357, nr 8, cmd response 0x900, card status 0x80000b00
[   22.563753] mmcblk0: retrying using single block read
[   22.582189] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[....] Configuring network interfaces...iactl[SIOCSIWAP]: Operation not permitted
iactl[SIOCSIWENCODEEXT]: Invalid argument
iactl[SIOCSIWENCODEEXT]: Invalid argument
done.

#13

Can you do the following. Connect your computer via ethernet. Take a screenshot of the following: go to the terminal and type in ifconfig and posting the results? And you post a picture?