DexterOS green light, but no wifi


#1

NO WIFI

I have followed the instructions found at https://www.dexterindustries.com/dexteros/get-dexteros-operating-system-for-raspberry-pi-robotics/ multiple times and always get the same result.

I’m using:
-Raspberry pi 3 model B
-GoPiGo3 (red board)
-DexterOS 2.2.2

The gopigo boots up and the green wifi LED is illuminated, but the SSID doesn’t show up in my list of available networks.

I’ve tried searching for it on:
-Windows 10 desktop
-Linux Mint desktop
-Android phone
-Ipad 3
-Chromebook

I’ve re-flashed the image several times on multiple 16GB SD cards.

What am I missing?


#2

@donaldprather9112

That’s  odd. . . .   We’re obviously missing something simple here.

A balls-up on Windows 10?  OK, I’ll buy that.
Linux?  Possibly.
Mint?  Less likely, but still within the realms of possibility.
All the others?  I can see this happening on each of those too.

But every stinkin’ one - all at the same time?   No.

I’m just shootin’ from the hip here, but if it were my  'bot, these are the things I’d try first:

  • Are you running off of the included battery pack, or a 5v supply plugged into the Pi?  The requirement is a fresh battery-pack.  People can, (and have), used a 5v wall supply plugged into the Pi’s power port for programming, (to save batteries); but for troubleshooting purposes, we’ll want a fully charged set of batteries in the 'bot.

    • Even if you DO  use an external power supply, it’s gotta be a beefy one.  Anything less than 2 amps won’t cut it.  What makes it worse is that not every run-of-the-mill power supply that claims  a 2 amp capacity, actually HAS  a 2 amp capacity.
      (Go ahead, ask me how I know.  I dare you!)

    • The Dexter-supplied power supplies, or the “official” Raspberry Pi 3 supply that delivers something like 2.++ amps, is what I’d get.

  • You can remove a wheel, (depending on how it’s assembled), connect a monitor, mouse and keyboard, and boot it up live.  You can even log-in, (as a very  limited-rights user), and snoop around a bit.  (Credentials: jupyter/jupyter)  Error messages on boot-up are a good place to start.

  • Have you verified that the Pi you’re using can access any  network via WiFi?  While it’s plugged into a monitor, mouse, and keyboard - try booting up a recent Raspbian image and see if you can go on-line that way.  This will prove if networking is working or not.

  • Don’t be offended if this sounds like a stupid question, but does your particular Pi come with WiFi built-in, or do you add a USB dongle?

    • Some versions of the Pi have WiFi built in, others don’t.

    • If you’re using a dongle, it may not be supported by DexterOS even if it IS  supported by the Pi itself.

  • Have you tried running Raspbian for Robots?  That system can do a lot of things that the DexterOS can’t.

  • Have you tried a different Pi?  (Yea, like everyone’s got a dozen-or-so Pi’s laying around with nothing better to do - right!)


Don’t get over complicated looking for solutions.  My money’s on it being one of those head-smackingly stupid solutions that will make you wonder how you could have ever missed it.

Let us know what you find.

Jim “JR”


#3

Thank you for the response.
I’ve been powering the bot through the battery pack.
I have a Mean Well power supply that I can get up to 6A at 5V out of. If that doesn’t work, I think it’ll be safe to say it’s not a power issue.
I’m using a Raspberry Pi 3 model B, so yes it has built-in WiFi.
I’m pretty sure I have 1 or 2 older Pi’s around here I can try, I just wanted to avoid using a dongle if possible. I also have a RasPi Zero W. I just don’t feel like soldering the i/o pins on it if I don’t have to.

So, I’ll try the power supply. If that doesn’t work I’ll just install Raspbian for Robots. If that doesn’t work, I’ll remove the Pi and throw it against the wall before starting from scratch with a different pi.

Hopefully I’ll be updating this with a solution before it comes to that :slight_smile:


#4

You say the antenna LED does turn green? Not just the one next to the power button?
If so, that’s very very odd. If the antenna LED is green, then the Pi has booted up properly.

Before you do something drastic can I ask you to boot up with an empty usb drive plugged in? Some logs files will be written to it, which you can then share with us to see what’s going on.
It’s the less drastic approach.

Cleo


#5

WiFi_Log.txt (14.4 KB)


#6

I was only allowed to upload one file. Do we need to look at the syslog files as well?
Also yes, the antenna LED is green as well as the power LED which is also green.


#7

I’ve upped your user level from ‘new’ to ‘regular’ .
We mostly need the system log file, thanks


#8

12_Systemlog_2018_08_11__12_59_04.txt (44.1 KB)
13_Systemlog_2018_08_11__13_31_06.txt (40.5 KB)


#9

Thanks a lot for the uploads.
I’m mystified. The robot is broadcasting its access point.
So why isn’t anyone seeing it???

I’m getting a co-worker to take a look too. Two heads are better than one.

Cleo


#10

Yes, I saw that too… WiFi Broadcasting SSID: GoPiGo
Aug.
:thinking:


#11

What if you click on “Other” and enter it manually? I’m curious


#12

Hi @donaldprather9112,

The WiFi LED turns to green only when 2 critical services for the WiFi functionality are running, otherwise it stays off. It’s quite hard to think the LED is wrong about it. So basically, the software is telling us it’s all working within the parameters, but in reality it’s not.

Then, it’s also the fact that your devices don’t see the Raspberry Pi’s access point. It’s close to being impossible for them to be wrong / not work.

Having these 2 assumptions in our head, I think the next step for you is to test the Raspberry Pi on a Raspbian For Robots / Raspbian image and see if you can connect to a WiFi. If it works, then move on and try setting up hostapd on that image following the Foundation’s tutorial:

After setting up the access point on yours, if it still doesn’t work, then it clearly is a hardware problem with the Raspberry Pi and it has to be replaced.

If you have another Raspberry Pi 3 around you that you know it works, I’d actually try that one out instead of burning an image and then follow all the steps in the tutorial as this latter option can take more time.

Let me know how it goes for you.

Thank you!


#13

I’ve tried that as well.


#14

Thank you. I’ll give it a shot!


#15

Donald,

Applying what I know about WiFi and radio in general - the only thing that makes sense is that, God only knows why, your WiFi chip may not be seeing the required antenna load. (i.e. the antenna may be broken/not connected.)

That would absolutely cause the problem you’re seeing. As far as the Pi and the software is concerned, everything is Hunky-Dory because many WiFi implementations don’t report reflected impedance or SWR - or if they do it’s a pain to get the info. (Or, the device using it doesn’t really care.)

You got my curiosity so riz, that I actually took apart my 'bot so that I could take a really good look at the Pi’s PCB.

Looking at my board I don’t see anything that strikes me as being an obvious antenna. I grabbed two pictures of the Pi-3B (not the B+) from Sparkfun’s site here.

The small beige part in the upper left corner - marked with an arrow and circled - looks like some kind of ceramic antenna. I’ve never seen a ceramic antenna element before, but this might be one.

This is the back of the board, (also from Sparkfun), and the circled area may well be the radio. The very shiny IC (on the left in the circle), is probably the radio chip. It’s interesting because usually the radio is either in a metal cased IC, or is in a metal shielding can. The item to the right appears to be some kind of ceramic device for matching the radio to the antenna - since it’s “output” leads directly to a through-hole to the ceramic antenna on the other side.

Guess what! It looks like I was right!

MagPi, Issue 43, talks about the “new” Pi-3 and has some nice illustrations of the ceramic antenna and the radio chip.

Look at the devices around those and see if anything looks damaged or missing.

Let us know what you find.

Jim “JR”


#16

It was a bit easier to see in black and white, but you can see a small chip in the corner of the radio. I looked at it under a microscope and it’s definitely broken. I’m going to solder the pins on my zero and try it out this weekend. It has a radio that looks the exact same aside from the missing chunk. I think you’re onto something here!


#17

If that came from Dexter with the robot kit, they may do an exchange for you.