Did anybody successfully flash new firmware?


#1

I don’t know what I’m doing wrong:-( I tried two different Arduinos (a Sparkfun RedBoard(UNO) and a Mega ADK) but every attempt ends in
"avrdude: stk500_recv(): programmer is not responding"

The heartbeat LED flashes as expected. When I try the first `avrdude erase’ command, the programming LED flashes a couple of times followed by the error LED. Then both go out and avrdude eventually prints the above error message:-(

Any ideas?

I tried with & without external power to the BrickPi board as well as with and without the attached Pi.

My base is an Ubuntu 14.04 64bit laptop;-)

Thanks,
– Marco
The Reset cable is really plugged into D10 even when it’s hard to see in the picture.


#2

Just a quick look at the setup, the reason this might not be responding is because the reset line on the avr cable needs to be disconnected. You’re inadvertently resetting the Arduino I think without it disconnected.


#3

Yes, that was it. Thanks.

I tried to follow the steps @ Flash Firmware using an Arduino.

Now using using all jumper wires instead of the ribbon and leaving the #5 (Reset) disconnected, things worked;-)

Tonight, I will check how badly I broke things;-)

Thanks,
– Marco


#4

It actually worked;-) The first test of my new wire protocol extensions was accepted by both ATmega’s and they even returned what I wanted;-)

So, now I only have to write the Pi side of my new motor control methods.

Thanks,
– Marco


#5

I created a custom programmer cable, which uses all six pins on the BrickPi side and five plus one on the Arduino side. The Reset wire connects D10 on the Arduino to the Reset pin on the BrickPi ISP connector. Now I only need to connect that six pin connector to both programmer ports, no extra reset cable needed;-)

Thanks,
– Marco