Error: Can't resolve host


#1

Attempting to install BrickPi Module I get the error :“Unable to resolve host DexterIndustries”. Same error when I try sudo apt-get update.

Any thoughts?


#2

Hey Bret, can you give a little more background?

Sounds like you’re not using the DI image. Correct?

What directions are you following to setup the BrickPi?

Are you sure you’re connected to the internet? If you’re getting this error when running sudo apt-get update, are you sure you’re connected to the internet? You can test this with the command line command:
ping google.com

What do you see when you run the above command?


#3

Yes, I’m using a fresh (Pi2 ready) DI image. I am conected to the net (able to VNC, and Google from the connected RPi). I’m not at home so can’t ping, but I am certain of what will happen when I do.

The “can’t resolve host…” is followed by successful activity as if the command is pulling files from multiple hosts and only DI is throwing an error.


#4

Sorry, you’e able to google from the connected RPi. That means you’re able to use google in the web browser?

And you’re getting this error with sudo apt-get update when you’re connected to the internet?


#5

Exactly. I will try again when I’m home this afternoon. If the error persists I will log the text.


#6

The error persists. No problem surfing with the Pi and the Google ping shows no problem.

Have a look.


#7

My new BrickPi board passes the firmware check with EV3 sensors! So that’s something. It does not seem to matter if the sensor button is pressed or not. Is that the expected result?

P.S. It also doesn’t seem to matter if the touch sensor is connected at all. That is very reasonable for a firmware check, but given the clear instructions to attach the touch sensor to S4, it is a bit surprising.


#8

Ok, I’ve just figured something out. The host “DexterIndustries” that can’t be resolved is local to my machine. When I transferred the new disk image onto my SD card, I renamed the host “DexterIndustries” (with sudo raspi-config) so that I could quickly recognize it as distinct from other Raspberry Pi’s on my home network.

It is still unclear to me why I’m getting an error. I also don’t know if the error implies anything meaningful about the update process. But at least I now know where the problem is.


#9

What I have learned is that it is the fact that I altered the host name of the DI image that caused the error.

Could you, John, or someone remind me of the original host name so I can confirm?


#10

Hey Bret,

Looking at that, it looks like you’re getting somewhere. If the firmware check works using Python, looks like things are installed correctly.

The original host is raspberrypi
You should have a bas script of something like pi@raspberrypi.local

Congratulations? :slight_smile:

Best,

John


#11

Interesting. When I change the host name back to “raspberrypi” I still get the error “Can not resolve host” when I run the Dexter Industries updater, and also when I run sudo apt-get update.

The processes run, and seem to work, but the first thing they do is report this failure.

Is this an error in the original image that has nothing to do with my configuration?


#12

Huh. So that’s the only problem, it throws an error when trying to contact Dexter Industries? That’s strange, haven’t seen that one. But it appears the sudo apt-get update is working fine?


#13

Well, I don’t know who or what it is doing. It says it can’
t resolve host, but host appears to refer to my Raspberry Pi. This happens no matter what I set the host name to. But then the process continues without a further error.