Errors when running install.sh from Git


#1

I have a brand-new BrickPi and a Raspberry Pi B. I installed Raspbian wheezy (2015-05-05) and updated it, then I followed the “Modify your own image” instructions at http://www.dexterindustries.com/BrickPi/getting-started/pi-prep/ to get https://github.com/DexterInd/BrickPi.git and run install.sh.

The end of the install process has several errors. Are these normal, or did I do something wrong?

...
Removing blacklist from /etc/modprobe.d/raspi-blacklist.conf . . .
==================================================================
grep: /etc/modprobe.d/raspi-blacklist.conf: No such file or directory
sed: can't read /etc/modprobe.d/raspi-blacklist.conf: No such file or directory
I2C removed from blacklist
grep: /etc/modprobe.d/raspi-blacklist.conf: No such file or directory
sed: can't read /etc/modprobe.d/raspi- lacklist.conf: No such file or directory
SPI removed from blacklist

Adding I2C-dev and SPI-dev in /etc/modules . . .
================================================
I2C-dev added
i2c-bcm2708 added
spi-dev added
Setting up i2c speed...
gpio: Warning: File not present: /dev/i2c-0
gpio: Warning: File not present: /dev/i2c-1
Setting up UART clock speed...
Enabling serial pins...
Disabling Serial Port Login...
Already Disabled
Traceback (most recent call last):
  File "setup.py", line 14, in <module>
    install_requires=open('requirements.txt').readlines(),
IOError: [Errno 2] No such file or directory: 'requirements.txt'

Restarting
3
2
1

Broadcast message from root@raspberrypi (pts/0) (Mon Feb  8 00:01:05 2016):
The system is going down for reboot NOW!


#2

bkendig, not sure, we haven’t run this in a while. Is there any way you can use our pre-setup image Raspbian for Robots?


#3

I’ll give that a try, but since the BrickPi modifications to the default OS are fairly minor, I was hoping to use the installation script on top of a default OS installation.

Are you certain that your pre-setup Raspbian for Robots image will continue to work even after I run apt-get upgrade?


#4

Pretty certain, I just ran it yesterday.


#5

I think the problem with the install.sh script that might be causing problems is

sudo python setup.py install

That line is trying to install BrickPi Python. You’re better off cloning that repo and installing it from there:

https://github.com/DexterInd/BrickPi_Python

I think you just need to run setup.py from that directory and you should be good to go.


#6

Cool, thank you! I was intending to use Python anyway. :slight_smile:

I’ll install BrickPi Python then run the BrickPi installer again (let me know if I shouldn’t).


#7

I just updated that installer.sh so it doesn’t call on the setup.py. Since there’s nothing in the directory anyway, it should be something done dependent on the language you’re running. I’ll try to make a more streamlined installation for this soon. Thanks for bringing it up!


#8

The errors at the end are gone now, but I still see the two “sed: can’t read /etc/modprobe.d/raspi-blacklist.conf: No such file or directory” errors, as well as these two:

gpio: Warning: File not present: /dev/i2c-0
gpio: Warning: File not present: /dev/i2c-1

I’m assuming these are harmless warnings, but I haven’t tried using the software yet.


#9

Does it work? If it works, they’re harmless. :slight_smile: