Ethernet to Mac Instructions


#1

I need assistance with the connection procedures to a Mac computer. Can I connect my ethernet cable to my Airport Extreme to access my Mac? What do I do once I’ve made this connection? I have Windows 7 running on this Mac with Parrallels, would it be easier to use this instead of the OSX software? Thanks. Jeff


#2

Not sure about Airport Extreme. However, you can do the exact same thing we did on our tutorial, but with a Mac. The only changes are where you setup the network.

You will need to locate the settings for your wired adaptor and check to see if the IP Address is configured automatically, or fixed to a specific value.

To get to network settings on Mac OS X:

  1. Load System Preferences.
  2. Click Networks.

This is a really good tutorial here (which is where we first learned how to do this!): http://pihw.wordpress.com/guides/direct-network-connection/
If you scroll down, it has info on how to use this setup with Mac.


#3

Hello Jeff, we’re you able to give this a shot?


#4

Hello Jeff, I just added steps for you and the Mac folks here:
http://www.dexterindustries.com/BrickPi/getting-started/using-the-pi/


#5

Hi There - Have VNC working via an ethernet cable between the BrickPi & Mac…
However, not able to get to the network (to get to github, or anything else)…
Sudo ifup eth0 && ifdown eth0 are showing no DCHP server available.

Advice??


#6

Hey MFiddler, the easiest way to do this is through WiFi. You can setup a bridge with your mac, where the BRickPi can connect to the interenet through your Mac, but I don’t know how to do that.

Easiest way: you’ll need to setup your “interfaces” file to connect to your local wifi network. You can modify the file “interfaces” in /etc/network to connect to your wifi network.


#7

No luck connecting with WiFi, but totally uncelear to me what to do.
Tried making sensible inferences from the ‘connecting with Wifi’ instructions on your setup page, and also tried the instructions from Adafruit (
http://learn.adafruit.com/adafruits-raspberry-pi-lesson-3-network-setup/setting-up-wifi-with-occidentalis).
No luck.


#8

Ok, so what went wrong with the adfruit tutorial?

Can you send screenshots of your interfaces file opened in nano? Can you send a screenshot of running ifconfig results?


#9

Unsure what went wrong, having a hard time trouble shooting so appreciate any tips.
Attaching the screen snapshot of “ifconfig” results.
Thanks!


#10

Sound the trumpets - it’s working after I fixed a typo in the “/etc/network/interfaces” file.
However, can you please reveal why under eth0 gives the address I assigned when my I first set up the interfaces file following your instructions and had
"iface wlan0 inet static
address 169.xxx.xx.xx
netmask 255.255.255.0
network 192.168.1.1
broadcaset 255.255.255.255
gateway 192.168.1.1
wpa-ssid xxx
wpa-psk xxx
"
BUT NOW my interfaces file has just plan old
"iface wlan0 inet dhcp
wpa-ssid xxx
wpa-psk xxx
"
SO - HOW IS MY RPI REMEMBERING THAT OLD ADDRESS (the one that starts with 169…, the one I am using to VNC in?
AND MIGHT THAT ADDRESS CHANGE, and if so how will I VNC in?
Thanks!!


#11

Hey MFiddler, we’re sounding the trumpets. That’s fantastic news!

Regarding this shifting IP addresses. I’m going to go out on a limb here and try to explain . . . I could have the wrong idea!

wlan0 is the wireless lan adapter: your wifi adapter. You’ve set that up so it runs DHCP (the IP address is assigned dynamically so we’re not setting it beforehand). So that will (might) change every time your Pi logs into your wifi network.

The IP address starting with 169.xxx.etc is the ethernet adapter IP address. This should still be static. In the screenshot, you can see that eth0 (the ethernet / LAN adapter that I assume is plugged into your laptop) has the IP address 169.254.xx.xxetc). So if you fun sudo ipconfig now, I suspect (and hope!) that your eth0 address will be 169.254.etc, and your wlan0 will be a number starting with 192.168.xx.xx.

Does that make sense?

Bottom line question: are you able to work on your Pi through the ethernet cable and VNC, and also access the internet?


#12

Hi, I’m glad to see a tutorial explaining the use of Mac with BrickPi robot.

Seems to indicate that the Microsoft word processor “Windows” is required for this step in the instructions. Is that correct ?

By “network adaptors” or “wired adaptors” you are referring to the ethernet cable, correct ?


#13

Yes, those seem to directly associated with Windows. You can see int he pictures, they’re using a windows machine. If you scroll down to the heading “Mac and Linux:” you’ll find more information on the Mac and Linux.

Yep, you got it: “network adapters” refer to the ethernet connection.


#14

Thank you for this response!

Can you tell me to what extent the rest of the article pertains to the Mac? Plan to use this computer for the rest of this exercise, if possible: iMac with Mac OS X, 10.6.8.

I tried pinging from RPi to iMac:

pi@raspberrypi ~ $ ping 169.254.“XY.ZD”

response from RPi to iMac:
PING (169.254.XY.ZD) 56(84) bytes of data.

Am I wasting my time here? The tutorial does look Windows specific.

Thanks again,
RaspAT


#15

Step 1 of the tutorial link you gave is the only mac-specific step I believe.

I’m a little confused by what you’ve added here. When you type “XY.ZD” are you literally using those digits or are you using numbers?


#16

My Bad.

I should have used, “xx.xx” or something else. Did not mean those (XY.ZD) as literal.

Thanks, I hope you can give me some info about whether that response from the iMac back to the RPi was correct or expected, or not.

Appreciate your help,
RaspAT


#17
pi@raspberrypi ~ $ ping 169.254.”XY.ZD”

response from RPi to iMac:
PING (169.254.XY.ZD) 56(84) bytes of data.

You should see some responses or failures after this . . . are you sure that’s all you saw ? you should see something like:

64 bytes from 169.254.XY.ZD: icmp_seq=0 ttl=45 time=10.000 ms

. . . . .

Or a failure remark . . . something like “Ping failed!”