EV3, motor doesn't move


#1

Hey guys! I recently tried running a EV3 motor, but nothing worked. I was able to get encoder readings, but no movement. I tried the examples, and writing my own tests. Is it working for anyone?

I can’t test or out because I tried it on someone else’s robot. I only have the NXT.
Is this a bug? It works fine with the NXT motors so … ?


#2

I only have EV3 motors and they work fine on both my Brick pi+ and Brick pi 3


#3

update:
now it works, see below!


#4

I observed that the battery power had been low for my BrckPi3, but even when having exchanged the batteries I had an unexpected connection failure and SPI was not detected any more.

After shut down and restart now everything works fine with the new battery pack, for all 4 EV3 motors!


#5

See section 3 here (specifically “More Information on Power”) for information regarding power options. See also section 2 here regarding the LED voltage indication, including when the motors get disabled.

All three types of NXT/EV3 motors work with the BrickPi3, but they will automatically be disabled from running if the battery voltage is too low (see the pages linked to above for details).


#6

yes, that was definetly the reason for my issues I had run into, not sure if that is also the reason for the OP’s reported issue though.


#7

Thanks guys! That probably was it.


#8

It would be nice if an error was raised if tried to run a motor on low power @matt.


#9