Faulty Brick Pi?


#1

I want to give this a try. I added a Brick pi to my raspberry pi and haven’t had any luck getting lego NXT motors to work. I’ve disabled the IR sensor that you mentioned on an earlier thread. I’ve updated software. I am trying to run a simple LEGO-Motor_Test.py. I have opened up this program via the terminal, and get alternating Run Forward, Run Backwards Commands on the terminal. I have tried multiple motors (in multiple ports, but mainly use MA) and nothing works. After typing python LEGO-Motor_Test.py, is there any other action required to run this program (other than see Run Forward, Run Backward)? Is the brick pi faulty or is it operational error?

If it isn’t obvious, we are new to python and raspberry/brick pi…


#2

Hey dpepper713, two questions:
1). Are you using Raspbian for Robots?
2). Are you using sudo python LEGO-Motor_Test.py ?


#3
  1. Yes, we are using dexter industries Raspian for Robots software.
  2. Yes, we tried the sudo python LEGO-Motor_Test.py

We can’t get the brick pi to actually make the motors work.


#4

One other thing, is the Brick Pi compatible with a Rasp Pi 2, Model B 1GB?


#5

Hey dpepper, can you post a picture of your setup? Also, where did you purchase the BrickPi and when?

To answer your question, yep, the BrickPi is compatible with the Pi2 and all versions of the Raspberry Pi. Which version are you using?


#6

Did you turn off the IR Receiver stuff?