First time install - motors not working


#1

Hello,

I’ve just purchased a BrickPi3, got the OS installed, and tested with the

~/Dexter/BrickPi3/Software/Python/Examples $ python LEGO-Motors.py

the touch sensor worked, but the motor doesn’t. the output is:

Encoder A: 0 B: -2 C: -1 D: 0
(motor connected to port C). it was similar for ports A and B. Not sure how to debug this.

other things I tried - my first attempt was my own install of Raspbian, and running the Dexter script as described. this is my second attempt, reflashing the SD card with Raspbian for Robots and it still doesn’t work.

any help would be appreciated! I’m an experienced Linux users, and know the EV3 pretty well, but am new to Raspberry Pi and BrickPi.

thanks!


#2

Make sure your battery is connected. Then try running the Read_Voltages script in the same folder.
The motors will be disabled if the voltage drops to a certain point so that the Raspberry Pi has enough power to live. If the voltage is below 7 volts I think the motors shutdown. So you may need a fresh set of batteries.


#3

I am plugged into the power supply directly, so no batteries. Pretty sure the voltages should be fine. I’ll double-check that, but if that’s the case there are bigger issues. thanks for the reply. Any other things to check?


#4

You cannot run the motors off of the AC. The BrickPi3 hat sits on the pi and receives power from it. However the pi can only deliver 5V to the hat which is not enough to power the motors. The battery pack is needed to run the motors.


#5

well, that worked! funny I didn’t notice that in the building instructions, but it makes sense. thanks! I have a few other questions on different topics, which I’ll post on the forum later. thanks for the help! as a side note, is there a typical way of attaching the battery pack, or do people usually just build a custom lego cage around it for their particular robot?


#6

You unfortunately have to build your own. I typically will build some lego thing to hold it or I’ll use rubber bands to hold the battery down on the legos.


#7

nice idea about the rubber bands. I keep getting stuck in the “only legos” mentality. :slight_smile: thanks!


#8

Or if you have a 3d printer…