[Fixed] ImportError: No module named 'auto_detect_rpi' Unsupported RPi version ''

I have this issue: sudo bash /home/pi/Dexter/GoPiGo3/Troubleshooting/all_tests.sh

===============================

GoPiGo3 Troubleshooting Script

===============================

Checking for hardware, and checking hardware and firmware version.

==================================================================

GoPiGo3 firmware needs to be version 0.3.x but is currently version 1.0.0

I checked this previous question: [SOLVED] NodeJS application failing with undefined firmware version message and tried what it is recommended but still not working any help would be highly appreciated!

Sounds to me that your Dexter Industries Software on your SDcard needs to be updated.

Updating GoPiGo3

=== Complete Update of Stretch and R4R (all DI software) ==

Open the Raspbian For Robots / GoPiGo3 Desktop,
Dbl-Click “DI Software Update”
Click Libraries and Projects: Update Dexter Software
Reboot

or via remote ssh:

sudo curl -L dexterindustries.com/update_r4r | bash

=== Update only GoPiGo3 software to latest:

sudo curl -kL dexterindustries.com/update_gopigo3 | bash

=== Update only DI Sensors

sudo curl -kL dexterindustries.com/update_sensors | bash

Thanks cyclicalobsessive, checking

You need a file named init.py (two underscores on each side) in every folder in the hierarchy. This is what python looks for to know that it should access a particular folder. The files are meant to contain initialization instructions but even if you create them empty this will solve it. To get rid of this error “ImportError: No module named”, you just need to create init.py in the appropriate directory and everything will work fine.

In this particular user’s case, the problem was an incomplete installation of the Dexter Industries software.

1 Like