Getting started with BrickPi3

brickpi3

#1

Hi,

I’ve been looking around the forum posts, but and I see people have had the same problem as me, but none of the suggested solutions seem to work. I have a BrickPi3 with a RPi3, but I can’t seem to get it to work. I’ve tried the CINCH and Raspian for Robots images linked on your website. I can connect to the RPi no problem, but not the BrickPi3.

When I start Scratch I get the message:
“BrickPi Scratch: Scratch is either not opened or remote sensor connections aren’t enabled”

When I run the Test and Troubleshoot I get: “No SPI response”

I’m powering the BrickPi3 with the battery pack. The lights come on and it powers the RPi. I just can’t get the BrickPi to do anything. I’ve tried following similar examples that I’ve found on this forum, but nothing I’ve found has worked so far. Is there anything else I can try?

Thank you.


#2

Hi @rick.mccourt,

Can you tell us exactly what steps you have followed in a step-by-step manner? Even though you have followed all suggestions on the forum, this still doesn’t tell us in what state your system is found.

@Matt, I’m going to bring you in this one, just in case.

Thank you!


#3

Hi,

I started at https://www.dexterindustries.com/BrickPi/brickpi3-getting-started-step-1-assembly/

I followed the “Download and use our software on your own SD Card”. On separate attempts, I tried Raspian for Robots by Dexter Industries (2018.06.27) and Dexter Industries CINCH (2018.01.29). I installed it on my own SD card using Etcher as described in the instructions. The install appeared to be successful and I am able to use VNC and see the desktop.

But, after that none of the steps work. When I start Scratch, I get the message: “BrickPi Scratch: Scratch is either not opened or remote sensor connections aren’t enabled”. And when I run the Test and Troubleshoot from the desktop I get “No SPI response”.

Does that help? If there are any other tests I can run to let you know more about my setup, please let me know.

Thank you!


#4

Hi @rick.mccourt,

Did you try running this command?

curl -kL dexterindustries.com/update_brickpi3 | bash

Preferably, do a reboot after this command finishes.

Thank you!


#5

Hi. Sorry for the late reply. I was out of town for a couple weeks.

I tried that command. It seemed to update without any problem. But now, when I start Scratch I don’t see the controller window running in the background and it still says “No Robot Found”.

Also, when I run the “Test and Troubleshoot” from the desktop, I still get “No SPI response”.


#6

What is the version number on the BrickPi3 board? It’s on the bottom of the PCB near the power switch. Can you share a few pictures of your setup, so we can see that the BrickPi3 is properly connected etc.?


#7

v3.2.3





#8

@rick.mccourt
thank you for the photos. Everything looks fine.

Since you can VNC into it, could you do the following?

Start a terminal window and type in the following:

ls /dev/spi*
followed by the enter key.

Please let us know what the system answers to that command,
Cleo


#9

output


#10

Thanks.
SPI is just fine. So what is it complaining about? (Rhetorical question…)

Also in a terminal, try:

cd ~/Dexter/BrickPi3/Software/Python/Examples
python Read_Info.py

What does it say?

Cleo


#11

Read_Info


#12

Thanks @rick.mccourt
It would seem SPI is not installed properly for some unknown reason.

Can you try
sudo raspi-config
Using your arrow keys (the mouse won’t work), go down to option 5 “Interfacing Options” and press Enter.

On this new screen, go down to SPI

Select Yes on the next screen, followed by Ok on the screen that follows.
yes

Use the Right Arrow to select Finish and press Enter

Reboot and try your BrickPi again.

Cleo


#13

I followed those steps, but still get the same response:

No SPI response


#14

Try updating the BrickPi3 firmware by running this command:

sudo bash /home/pi/Dexter/BrickPi3/Firmware/brickpi3samd_flash_firmware.sh

You can follow the instructions here.


#15

Here’s the output. I didn’t get the ** Verified OK ** message.


#16

Is the BrickPi3 the only thing connected to the RPi? Try turning off the RPi and BP3 (and removing power), and then booting and running the command a few times to see if it will successfully flash the FW.