GoPiGo boot - no green WiFi light but WiFi enabled, can't connect


#1

I have a GoPiGo 3, mounted on a Raspberry Pi 3. Running DexterOS 2.1.2 from a Dexter SD micro card.

I turn on the GoPiGo, the primary LED blinks green for a while then solid. The WiFi LED does not turn on. But the GoPiGo starts broadcasting an SSID.

Connect to the SSID on a laptop, type MyGoPiGo.com in the browser and get the Dexter Industries screen. Upper left corner says “Connected to GoPiGo (PI ONLY)”

I click on the box that says “Start coding in Bloxter” but the next screen says "“You are not currently connected to a physical robot.”

Any idea what’s wrong?


#2

Hello @woody
Thanks for contacting us, we are currently trying to figure out what’s happening. A couple of robots seem to be having a similar problem and we think we may have a way of fixing it.
Would you be willing to test it out? I will send you a file that you will need to put onto a usb drive, connect the usb drive to the raspberry pi, and boot up the robot.
We’re finalizing internal testing right now. I should have a file for you within 30 minutes or so.

Cleo


#3

You bet. Let me know what to do. I’m reasonably acquainted with Windows.


#4

You can download the update from here, and install it following the instructions here.


#5

I need Google Drive permission - or you can just email the zip to me.

If I understand the instructions, I just copy the zip file to the USB drive, insert the USB drive in the Pi, and reboot. Yes?

Thanks


#6

My apologies. I have granted access to the file. And yes, you just copy it onto a usb drive, plug the usb drive into the Raspberry Pi, and boot up. It will take its sweet time to boot up, be warned.
There is no danger to your robot, but I am not 100% certain it will work.
It worked on a simulation of what I think the problem is, however I’m not sure it is representative of your problem.
Thanks for being willing to try!
Cleo


#7

You bet. I’ll get it installed in the morning.

Just to be clear – the single zip file which contains five zip files should be copied onto the USB drive?

Let me know if you need some debugging help. I don’t know the Pi, but I’ve done Windows debugging for years.


#8

Well, if you’re willing, put in a usb drive that has only that one zip file. After the update, some log files will be written to the drive. I’d appreciate if I could get those log files, thanks!

Cleo
who just spent the evening debugging a windows laptop.


#9

Got the same results.

The Zip file is gone from the USB drive, but I have a new folder called Logs.

The contents of that folder are attached.

(My son renamed the gopigo to potatoprime, if that makes a difference.)

P.S. If I can help with the Windows debugging, let me know. It’s kind of my bailiwick - see askwoody.com

– Woody

(Attachment Logs.zip is missing)


#10

Hi @woody

What a disappointment. With that failing, I really need a look at the logs, but the post says they are missing.

Cleo


#11

Argh. Your mail system only allows one attachment. I tried zipping the logs into a single file, but now I’m getting a message that it won’t accept zips. Can I just email them to you?


#12

(Or I can attach each file, one by one)


#13

Let’s do the one-by-one…1_Systemlog_2018_07_18__16_22_30.txt (60.5 KB)


#14

2_Systemlog_2018_07_18__16_30_07.txt (11.6 KB)


#15

Now there’s a speed limit - looks like 30 seconds between messages. 3_Systemlog_2018_07_18__16_31_31.txt (52.6 KB)


#16

4_Systemlog_2018_07_18__16_37_20.txt (103.7 KB)


#17

Sorry for the hassle. Yes you could have emailed them, but now they’re here so that’s fine. Thanks for the upload.


#18

Based on what I’m seeing in the logs, can you do one more test for me, please?
Boot up via usb power (as you don’t have a choice for now). Go to Code in Python. You should get a JupyterLab interface with a tab called Launcher. If the tab is not there, you can see a tiny little house to the left of the screen. Once in Launcher, you have access to a terminal, please open it.

Type in:
ls /dev/spi*

You should be getting:
spi

Can you please confirm?


#19

Step me through that slowly, please.

I’m booting the Gopigo using the AA battery pack, attached to the Gopigo. Is that correct?

I assume I then connect to the WiFi broadcast from the Pi, using a laptop. From there, how do I get to Code in Python?

I can read Python, if that helps.


#20

@woody

Use a usb cable to power the Pi directly even if you have batteries. It will be safest that way.
Connect to the Wifi broadcast, which should be called GoPiGo by default.
Open a browser, and go to mygopigo.com (or 10.10.10.10)

Click on “Code in Python” then follow the directions in my previous post.

Cleo