GoPiGo left motor fails on second command

gopigo3
#1

I just finished setting up my GoPiGo3, and am experiencing some strange behavior when I try to control the robot using the python api.

If I run the following in the python prompt

>>> from easygopigo3 import EasyGoPiGo3
No module named di_sensors
No module named di_sensors
>>> gpg = EasyGoPiGo3()
>>> gpg.forward()
>>> gpg.stop()
>>> gpg.forward()

The first gpg.forward() command works, e.g. both wheels spin. The second gpg.forward() command, however, does not work, e.g. the wheels start spinning but immediately stop.

If I then run

>>> gpg.right()

The right wheel spins, as it should. But if I run

>>> gpg.left()

The left wheel starts spinning but immediately stops. So something seems to be wrong with the left motor? But only the second time I try running it.

If I exit the python prompt and open a new prompt, the left motor will work the first time, but not the second time I command it to spin. When I get both motors to spin, they do seem to go at the same speed.

What could be happening, and how can I fix it?

Python api not installing correctly
#2

Hi @fvanbreugel,

Is the battery low on voltage? The power LED must be green in order for the motors to be actuated.

This could also happen if you were to try to control the GoPiGo3 from multiple execution threads. Is this happening in your case?

Thank you!

#3

I’m still having this issue. The power LED is solid green. I only have one execution thread, e.g. a single python terminal.

I tried reinstalling everything from scratch thinking that maybe something had become corrupt, but I’m having the exact same issue.