Python api not installing correctly

After running:

sudo curl -kL | bash 

I can’t seem to get access to my GoPiGo through python - I get the following error:

pi@raspberrypi:~ $ python
Python 2.7.13 (default, Sep 26 2018, 18:42:22) 
[GCC 6.3.0 20170516] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from easygopigo3 import EasyGoPiGo3
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "build/bdist.linux-armv7l/egg/", line 13, in <module>
  File "build/bdist.linux-armv7l/egg/", line 5, in <module>
  File "build/bdist.linux-armv7l/egg/", line 30, in <module>
IOError: [Errno 2] No such file or directory

What am I missing? I tried manually installing using:

$ cd ~/Dexter/GoPiGo3/Software/Python
$ sudo python ./ install

But that didn’t help either.


I am assuming you’re using Raspbian and not Raspbian for Robots?

if that is the case, can you run sudo raspi-config, select Interfacing options, and activate SPI ?

Let us know how it goes.

And also, if you did this on a pure Rasbian and you just had run the install command, then you’ll have to reboot the Raspberry Pi to take into effect the installation.

I was able to get it installed, however, I am still having a different issue detailed on this thread: