Grove Pi Zero - Digital Humidity and Temperature (DHT) sensor problem


#1

I am trying to get the Home_Weather_Display project working with Grove Pi zero.
It works fine if I use it with GrovePi and it, however, does not produce valid numbers when I use it with GrovePi Zero.

It shows -1, -1 similar to the issues reported in the discussion (
Raspi GrovePi Temperature&Humidity Sensor showing -1 -1 ).

I modified the script (https://raw.githubusercontent.com/DexterInd/GrovePi/master/Projects/Home_Weather_Display/Home_Weather_Display.py ) to use port 3 as I connected the DHT sensor to D3 using Grove Pi zero as shown below.

dht_sensor_port = 3

It works fine when I used GrovePi and Raspberryi 3 and it only shows -1, -1 when I switch to Grovepi Zero.


GrovePi Zero - High Accuracy & Mini Temp and Humidity Sensor
#2

I have tried both the available images 2017.10.05-BETA_Dexter_Industries_jessie and 2017.09.28_Dexter_Industries_jessie. from https://sourceforge.net/projects/dexterindustriesraspbianflavor/

Again, this problem is only for GrovePi Zero setup and not with GrovePi+Pi3.

Sometimes, I see a valid number at the beginning after reboot and immediately it goes to -1, -1.


#3

Firmware update as suggested in the following post seems to resolve the issue.
I can see the numbers more consistently.

###And here are some suggestions:

###And here are some suggestions:

Run the firmware update without any sensors or HDMI connected to the Pi. So, open a terminal and follow this commands.:

  • cd Desktop/GrovePi/Firmware
  • sudo bash firmware_update.sh

Then next, let’s reinstall the GrovePi dependencies (there might be something that’s still not set up). After you update the firmware, you’ll reboot it. So, open a terminal and follow this commands:

  • cd Desktop/GrovePi/Script
  • sudo bash install.sh
  • sudo reboot

#4

Hi,

I use Grove Pi Zero and DHT11. They don’t work at first. After updating the firmware, they only worked normally once. But after restart, the data I received was -1. Any idea?


#5

Hi @xudong.zeng,

Do you have a GrovePi+ around? If so, can you test the DHT11 sensor on the regular GrovePi+?
We want to see if it’s the same thing for both of our boards.

Thank you!


#6

Hi,

Sorry for the late reply. I test the DHT11 with GrovePi+ and Arduino, they works good. But with zero, I just got 0.

Best Regards,

Zeng


#7

Hi @xudong.zeng,

Both the GrovePi and the GrovePi Zero use the exact same firmware - also technically, they are identical, it’s just that the former one has more ports - that’s it.

Now, the only way this wouldn’t work is if the GrovePi Zero is either defective or the firmware hasn’t been properly flashed (or something happened with it). Could you reflash the firmware for the GrovePi Zero you’ve got?

Thank you!


#8

Hi,

Any progress to know why the sensor is not working?

Regards,

Michael


#9

Hi @Michael_Moore,

We’re working on it and as soon as we have something, we’ll make sure to let everyone know about it.

Thanks!