GrovePi problems


#1

Hi,

First of all, I don’t know where this topic goes, so I uploaded it to Uncategorized. Feel free to change it to the correct field.

I bought 13 Grovepi + base kit on 10/07/2017 with the company Modmypi. They were used just 6 days, but three of them suddenly stopped working properly. In addition, two GrovePi’s have the RST red LED permament on. Anyway, the problems are the next ones:

  • Two GrovePi’s does nothing (sensors doesn’t respond - nor input nor output ones.). I think that one board changes the color of the LCD, but nothing more.

  • The last GrovePi works quite well, but it has one problem: the LCD doesn’t display any text (it just can change the background color). Obviously, I tried the LCD with other boards and viceversa.

I talked with them but they redirected me to your web, saying that you are the ones that can give me support with that. Is there something I can do to repair them before doing a claim for hardware fault?

Thank you in advance.

Greetings,

Iván Lago


#2

I changed it to GrovePi because this is about the GrovePi.

This doesn’t necessarily mean it isn’t working. That being said it doesn’t necessarily mean your GrovePi is working…

I think the first step would be to make sure your doing everything properly and it is setup correctly. So I suggest goin through the Getting Started Guide . It will walk you through everything such as programming and updating your firmware. Which you really should everything, it may fix your issues.


#3

Hi @ivan.lago, I’m really sorry to hear about this. We will work to try to make this right.

For all three boards not working: can you run a test script on each and upload them? It would help if you number the GrovePi and link that to the test script. If you’re running Raspbian for Robots OS you can see an icon on the desktop to generate this.

If you’re running your own OS, this Readme has more information on how to run the test script from the command line.

For the last with the LCD screen; this is a little tougher because the LCD screen uses I2C directly tied into the Pi. Can you share the code you’re running for this?


#4

Hi @JohnC and @graykevinb,

I couldn’t answer before because the office was closed due to the holidays and I also was out these past weeks.

About the LCD code question, I use the one you have uploaded to github, but I also tried with some visual block for a course we got in July, and I get the same problem with both of them.

On the other hand, I run two different OS with the RaspberryPi + GrovePi: 1) Cisco Image that provided to us in order to explain the IoT course and 2) the Raspbian OS that it can be found in: https://www.raspberrypi.org/downloads/raspbian/.

Finally, I realized the complete test, and the results are attached in the three .txt that I provide (they are uploaded as a single txt file because the forum says that new user just can upload one file, and zips are not admitted).

Logs.txt (12.2 KB)

Thank you and we are on touch for any indication you can give.

Greetings,

Iván


#5

@ivan.lago these logs help quite a bit. It appears that the GrovePi libraries are not fully installed. When I look at Log_1 and Log_2, I see a lot of support packages missing. In particular, you have these missing:

wiringPi Not Found (ERR)
I2C still in blacklist (ERR)
SPI still in blacklist (ERR)


Check for addition in /modules
==============================
I2C-dev already there
i2c-bcm2708 not there (ERR)
spi-dev not there (ERR)

The third log indicates that everything is not installed correctly as well with the final error we see.

You will need to re-install the GrovePi software for Python and all of the supporting directories. Here’s what I recommend you do:

  1. If possible, download Raspbian for Robots. It will be ready to go and have everything installed. Here are directions on how to get it into your SD Card. This is the most reliable way to solve the problem.
  2. If you MUST use your image or the other image, you need to make sure you run the installation files. I would start with a fresh version of whatever image you’re using (so reburn your Cisco image or your Raspbian image) and then follow the directions here for installation. You can simply run the command sudo curl https://raw.githubusercontent.com/DexterInd/Raspbian_For_Robots/master/upd_script/fetch_grovepi.sh | bash and then reboot, this should get you back on track.

I would then re-test the LCD-Screens with the example programs in the GrovePi directory. If those work, you should be good to go!