HELP REQUIRED! Remote Connection to GoPiGo3 using Rasbpian for Robots

Hey guys,

Just today I downloaded the Raspbian for Robots for my GoPiGo. I set it up and the only way I managed to connect to the robot was with Ethernet Cable going on the:
" http://dex.local/ " page in my local browser.

There I could connect via VNC, and via terminal. Both the passwords were given on the browser page.

I continued to follow the instructions on this page:

But I got stuck on step F or step G. It says double click the Wifi Setup - something I cannot find.
And then it says select Manage Networks tab which I reckon is in the Wifi Setup.

The problem is that the pictures are missing and I am having a hard time figuring out where to find these items.

I successully logged in to my Wi-Fi just by clicking the Wi-Fi button and choosing the network then providing a password. But I do not know how to continue from here.

And I can ssh from my laptop to the robot using command:
ssh pi@dex.local
then providing the password.
But this works only when the robot and my laptop are connected with ethernet cable.

Can someone with more experiance with connections please help me?



Dump Raspbian For Robots and download GoPiGo O/S.

Raspbian For Robots has been depreciated for a long time now and a lot of the instructions are only relevant to GoPiGo O/S.

Unfortunately, the GoPiGo software web page still lists Raspbian For Robots as the penultimate O/S for the GoPiGo robot.

I have submitted requests, (plural), to correct the software support web page, however it appears that manpower and time constraints have delayed this.


Is the GoPiGo O/S the same as GoPiGoOS 3.0.3 ? Thr one that let’s you code in bloxter and in JupyterLab ?



That’s the one that lets you program in Bloxter, Jupyter lab, along with Python, C, C++, and whatever else you can download compilers and libraries for.


But for this I will not have a desktop interface like the Raspbian? Or can I do it. What I mean by this is the desktop thst shoes when you use VNC viewer when running the Raspbian.

Is there a possibility for something like this using the other GoPiGo OS ?


If you want to connect to the desktop remotely, you will need to install VNC player, (free), on the machine you want to use as the remote unit.

Or, you can use a keyboard, mouse, and monitor plugged into the robot for local development.

Anything and everything the other two software packages did, GoPiGo O/S can do better.

It’s also compatible with a wider range of hardware, up to the Pi-4.

Why not try it and report results?



Do you also visit the MSFS forums?  I think I remember your avatar from there.


Here is what I tried until now:

Initially I started eith DexterOS 2.0.3. Connected with my laptop to the robot via WiFi. I could only run files in the JupyterLab. But it was very limited since it is an old software.

Next I uldated to GoPiGoOS 3.0.3 the latest software that is available on the webpage per my information. I connected to it via WiFi. Yet again I could only run files through the JupyterLab. But also felt limited since I couldn’t connect to the internet.

Next, yesterday I got Raspbian for Robots. Followed the instructions and could only connect with Ethernet Cable. And then I could not find any other way to connect to it while the robot is not directly connected to my laptop via Ethernet Cable.
I got more freedom with running files with the Raspbian, since I was out of the JupyterLab environment.

My project consists of two parts:
One is Javascript Webpage where users will draw a graph. This graph will be converted to text file and downloaded as a text file.

Second part is, python script will read this file and make the robot move.

Problems I encountered:
DexterOS, GoPiGoOS: since i am stuck in jupyter lab i cannot download the file directly on the robot and it downloads it on my machine.

One more problem with these is actually running the html files. I haven’t found a way to just run the html file. I have to wrap it in a python and run it from the notebooks cells (since we are in the JupyterLab’s environment).

Raspbian solves the issues for me. I can run the html files just by double clicking on them and it downloads the text file on the robot, which I can later read with a python script.
However, I need it to be remotely connected so it can move freely and not be leashed with the Ethernet Cable.


If you connect directly to the robot via a mouse, keyboard and monitor connection, you will get the initial robot’s desktop like Raspbian For Robots.

If you open up the web page, you’re getting the basic web interface like Dexter O/S.  Here you can do important things like calibrating the wheel encoders and doing basic tests on the robot, the camera and servos, (if installed), and basic robot control of things like the eyes, moving around, etc.

If you want your robot to participate in a networked WiFi connection all the time, there are two steps you must do:

  1. Go to the web interface and click on the WiFi symbol.  This will take you to a network configuration page where you can select “networked” mode and connect to your local Internet WiFi network.

  2. Once you have successfully connected to your WiFi network, return to the desktop, open a terminal window and execute the following:
    (All on one line. . .)
    sudo systemctl disable start_as_access_point.service

Once you do that, your robot will always connect to your local network.

Pro tip:
To make accessing the networked robot easier, go to your network router and set up a DHCP lease with a specific IP address.  This will make the robot easier to connect to since the IP address will always be the same.

“Charlie Pi-4” is my robot.  There are two fixed leases - one for the WiFi interface and one for the Ethernet port.

On my (Asus) router I go to “Lan” => “DHCP Server” and down at the bottom of the page you can set a fixed DHCP “lease” - an IP address your robot will always get every time it starts.

You should do this while the robot is connected to the network as it will make it easier to find the specific MAC address.

Also note, (as shown in the screenshot), that you should do it for both the WiFi interface and the hard-wired Ethernet connection, so they both get fixed IP addresses.

Try it and let me know what happens.


Robot first boot with HDMI monitor connected.  Note the green antenna connector, (upper right), this means that the robot is in access point mode, but there’s nothing connected to it.

The robot’s desktop as shown on a locally connected monitor.

Connected to the robot’s access point.

Connected.  The antenna LED is now blue, indicating an active access point connection.

Navigating to the robot’s web page.

The robot’s web page.  Click on the WiFi icon to change the network mode.

Changing to networked mode.

When you are successfully connected to the local network, the antenna LED turns yellow.

Making networked mode the default when booting.  Type/copy to a terminal window:
sudo systemctl disable start_as_access_point.service

This is the remote desktop using RealVNC.  You can do this in both access point mode or networked mode.

Let me know if you have any questions.


When you change to networked mode and you set a fixed DHCP lease, reboot and check the assigned IP address.

In my case I forgot to hit the “apply” button so the fixed lease didn’t stick. :man_facepalming:



If you want to “have your cake and eat it too” with networking, you can leave the robot in access point mode and connect an Ethernet cable when you want to do something that requires network access.


Ok so apperently I had everything prepared and it worked:
First I turned on my robot:

Next my laptop terminal shows that there is a connection between the robot and the laptop. Since they are both connected to the same Wi-Fi probably:

So I can enter it from here like this:

And get this one without the ethernet cable:


So, apperently everything works as I intend it to work for now.

Thank you btw, for all the help. I tried to connect the GoPiGo OS or the 3.0.3 OS to the internet as you have shown me, but I don’t think I followed the steps correctly, I am getting to the Wi-Fi part and when I click to connect to a network the light goes green instead of yellow. But I am probably not choosing the correct network. I will probably come back to this some other day as for now I think I am able to make my project using the Raspbian.

I hope they make it so you can connect easier to the robot’s Dekstop through VNC using GoPiGo OS as far as I saw its much more nicer and smoother to work with than the Raspbian.

Thank you again for the help. I really appreaciate it. The deadline for my project is the end of next month so I should be finished until then. I will make sure to document my journey and to post as much updates as I can.


This is Raspbian for Robots.

I really need you to get on GPGOS.

There are significant differences between Raspbian For Robots and GPGOS that makes it difficult to get things working if you aren’t on the current software.  Or if we aren’t on the same page.

If the antenna light goes green again after trying to go to network mode, it means it wasn’t able to connect, usually due to a bad SID or password.

My ability to help you is more limited without you being on the latest GoPiGo operating system.  Can we concentrate on that?



Oh, I am sorry for the misunderstanding. I had the latest GoPiGoOS when I briefly tried your approach. But I only clicked the Wi-Fi button on right top corner. And it happened that the light went green after some time, and not yellow, but I think I chose the wrong network. I will try it again today but I think I can work on the Raspbian for the means of my project.

The images I showed were from when I used Raspbian. And not when I was using GPGOS.

I can provide images from the GPGOS as well if you wish, but as I said I think I will be able to finish my project, which will be portable to GPGOS as well once done, with slight tweeks of course.


Here is my progress on using the latest GPGOS:

I connected to my robot like this:
I turnet the robot on. I then connected via Wi-Fi.


Next I went to the webpage:

Clicked the Wi-Fi button and went here:

Here I specified the Wi-Fi I want to connect to and the password. And the robot went into network mode:

Now I have to connect it with HDMI cable to a monitor or to connect it with VNC right, so I can program it.

Since the page no longer works:


Sneaky trick:

When you boot the robot, if there’s a headset/powered speaker plugged into the audio port, the robot will speak the assigned IP address.

If you know how to configure the DNS server on your router, you can give the robot a fixed DHCP address so it’s always the same IP every time.

1 Like

You said there is a free VNC right? How do I set it up. So I can have remote view from my laptop but the robot is free to move.


Another thing you should consider doing:

Under the “raspberry” drop-down menu, in “Accessories”, there is a “SD card copier” utility that you can use to copy the SD card to another SD card plugged into a USB port.

Just in case your SD card goes sideways, you have a spare.

1 Like

RealVNC viewer:

Download RealVNC VIEWER, not RealVNC Connect.

You don’t need a subscription or the fancy version. Just download the correct viewer for your system, (Windows, Mac, etc.) install it, and you’re good to go.

You will need your robot’s IP address, the username, (it should be “pi”), and the password, (it should be “robots1234”), to create the connection profile.  If you check “remember password” it will log in automatically any future time.


This one right?