How do I fault find a new board


#1

Hi,
I have just purchased an advanced brickpi board, plus two brand new motors and cables. I have also downloaded the latest dexter image for my raspberry pi.

The Pi boots up and wifi is working.

Basically the motors do not move.

I have got past the first issue, powering everything via the PI, had not seen the comment about motors not working if only the micro usb is used. So I have got a nine volt battery on the brickpi and micro usb on the pi.

On boot up I have noticed an error message stating that module spi-dev is not found - is this required?

I started this post because I could not get my motors to run from python or scratch.

Still have not sorted the python issue out, I tried modifying wifi car.py to remove sensor and the thread.

Initially I could not get scratch to work, brick pi scratch output an error stating scratch not running or remote connections not enabled.

The default image for scratch has remote connections enabled, I solved the problem by disabling and then re-enabling. Now I know my motors are working I will crack on with the python problem and build my first robot.

For future reference, are there any communications between the pi and brick pi that can be monitored ?


#2

Hey windy54, can you try three programs in Python to verify everything is working:

  • LED_PWM.py
  • LEGO-Motor_Test.py
  • LEGO-Touch_Sensor_Test.py

The motor and the Touch sensor in particular will help troubleshoot the problem. What are the results when you run these three programs?