How to test BrickPi works


#1

Hi,

I bought a BrickPi last week and I’m having problems establishing if it works or not.
I’ve downloaded 2016.02.22_Dexter_Industries_wheezy.img and written it to 2 SD cards. One for my GoPiGo and one for the BrickPi.

The GoPiGo is up and running with the basic scratch programs operating as expected. So I’m assuming the image is fine.

When I plugged the BrickPi in to the 8 AA cell powerpack from the GoPiGo the provided power cable got very hot and the plastic sheathing for the cable has melted slightly.
So now I’m only prepared to run basic tests with the power coming from the Pi’s usb power supply.
I hooked everything up and tried to run the touch sensor scratch program. But it doesn’t seem to detect the touch sensor.
Are there supposed to be any lights on the BrickPi board itself ? Because it seems impossible to tell if it’s working.
Is there any easy way to test if it’s working ?
If it is working, how do I provide sufficient power to be able to run motors as I don’t think the supplied power cable is up to it ?

Thanks
Pie-man


#2

Hi Pie-Man,

When I plugged the BrickPi in to the 8 AA cell powerpack from the GoPiGo the provided power cable got very hot and the plastic sheathing for the cable has melted slightly.

It sounds like something has shorted on the BrickPi (hence the heated wire). Can you double check that there are no metal parts touching the BrickPi? Can you post a picture of how the BrickPi is setup?

Thank you, John


#3

The only parts that look like they’re touching are the USB and Ethernet connectors except of course the GPIO pins. Everything else is pretty clear of the Pi. There were no pads or anything included in what I received to space the BrickPi off the USB/Ethernet connectors, nor do I recall any warnings about ensuring there was something insulating the underside of the BrickPi board from the Pi. Nothing on the BrickPi board is illuminated to indicate it’s working, you can see the Pi is booted to the desktop in one of the photos.


#4

Hi Pie-man,

Thank you for sharing the pictures. A few thoughts: this is an older version of the Raspberry Pi. It looks like it was somehow damaged and the power has shorted (hence the melted power cord). the power cord looks like it’s dead; and I would imagine there is a short somewhere on the board.

Unfortunately, it looks like your best bet is to return it for a new one. I’m going to go out on a limb that this was purchased through a distributor?

Best, John


#5

Hi John,

That’s all correct. It’s a BrickPi Advanced, and being in the UK I bought it from ModMyPi.com. It was they that suggested I contact Dexter Industries via this forum after I’d contacted them first.
I didn’t realise at the time of ordering that the BrickPi had moved on another revision to the BrickPi+ when I ordered it.
I originally tried to build it with a Pi2 modelB, but the shift of the mounting points is such that the end 2 motor ports are mostly obscured by the vertical posts. So I had to dismantle an old project to retrieve the ModelB rev2 you see in the pictures.

I shall get back to ModMyPi and tell them you reckon it’s dead.

Thanks,
Pie-Man

p.s. - as an aside, do you know if a Pi2 (or 3) and this BrikPi Advanced board would fit nicely inside one of the new colour cases you do for the BrikPi+ Thanks


#6

Pie-Man,

They’re a fantastic distributor and they’ll honor the replacement. In turn, we’ll replace the damaged board to them. I would urge you to contact them about it.

The new cases will fit a B+ layout (so a 2 and a 3 will fit as well!), and the colored cases will work well for that size as well.

Again, I’m sorry about the hardware issues. Thanks for your patience and please let us know how the return goes and how the new hardware works.

Thanks so much,

John