Jessie image


#1

I want to use Jessie.
The reason fore this is that many programs are preinstalled already, like:

Wifi Gui setup (using the new architecture without inittab and so on…)
WiringPi
Scratch
Browser
Graphic text editor
VNC
Local support (for swedish keybord etc)
Python

Are you working on it?

Best match for me would be to have short tutorial to modify my own image with additional software, static Ip… using Jessie.

The reason for all this is that I could build img-files for every kind of new setup in minutes.
Is it possible to do a new short tutorial with the BrickPi addons?

Kind regards
Sebastian


#2

Hey Zebulon,

We’re currently working on a port for Jessie: https://github.com/DexterInd/Raspbian_For_Robots/tree/master/jessie_update

We probably won’t do a tutorial on how to generate a new image like this; it’s something we might be doing once every other year. However, you can install BrickPi to your own image.

Best,

John


#3

Hi John!

I understand. But, can you just make a short list ofcthe necessary BrickPi programs to install on my own Jessie image?

Regards
Sebastian


#4

I use Jessie

You first have to do the following setup:

$ sudo raspi-config

In menu ‘Advanced Options’ -> ‘I2C’ -> enabled
In menu ‘Advanced Options’ -> ‘Serial’ -> disable

Add this line at the end of /boot/config.txt
init_uart_clock=32000000

reboot

Then you can download from github the driver and examples of your preferred language.




#5

Thank you Philippe.
That was just what i needed. I’ll try that tomorrow.
:slight_smile: Sebastian


#6

Philippe, don’t you meant to enable the serial lines? BrickPi talks over serial.


#7

The BrickPi_Python LEGO-Motor_test.py still works when I disable the serial interface in raspi-config. I had problems with Rasp pi 3 getting odd io errors and tried that to see if it would fix it. Turning it off fixed the problem for me using Noobs 1.9.0. I had expected it to disable BrickPi, but oddly it got rid of the errors and the LEGO-Motor_test.py works fine. I let it run for about 15min without any problems. Something about the latast raspbian causes interference when serial interface is enabled.


#8

This option does not deactivate the serial interface. See this page for a detail explanation: http://www.raspberrypi-spy.co.uk/2013/12/free-your-raspberry-pi-serial-port/

“By default Raspbian configures the Raspberry Pi serial port (GPIO14-GPIO15) to provide boot-up information. It also allows you to login via a connected device. If you need to use the Pi’s serial port for something else (i.e. a specific add-on board) you will need to disable this default functionality.”

Jessie switched to systemd. /etc/inittab no longer exists. To disable this functionality it’s easier to use raspi-config.


#9

Just to complete, this menu is:

A8 Serial Enable/Disable shell and kernel messages on the serial

So, you have to disable shell and kernel messages on serial


#10

Hey phillipe,
We have just updated the Raspbian for Robots image to Jessie. You can find out more details here: http://www.dexterindustries.com/topic/jessie-raspbian-for-robots/.

-Karan


#11

We’ve just updated this again, if anyone was having trouble with the BrickPi, they should run the update.