Jessie Raspbian for Robots


#1

Jessie Pre-Release is now Available! We have just released a MAJOR upgrade with some improved networking, Pi 3 working right out of the box, and a much faster Jessie! The new image name is up for download on Sourceforge, for free!

We have a new, awesome version of Raspbian for Robots available for beta testing! Get a first look at our updated software, with new, more intuitive navigation and Scratch integration.

Important Note!

    The Hostname is now "dex" The Username is still "pi" The default password is now "robots1234"

You can download the image here on Sourceforge.

For a quick refresher on how to burn the image to an SD Card, see our guide on how to Install Raspbian for Robots Image on an SD Card here.


Beta Testers Wanted! Raspbian for Robots
#2

I’m curious, how did you get around the serial timing issue in the March 18 Raspbian/Noob? Did you use a new device tree or change the BrickPi drivers?

thanks

peter


#3

I just tried the new Dexter Jessie image and it has the same exact problem with the serial interface interference I described in other posts. Until Raspberry Pi foundation releases a new device tree, I don’t think using the default device tree with bluetooth enabled will work reliably with BrickPi.


#4

password robots1234 is invalid / not accepted
so what is the correct password please ?


#5

The password has not changed. Are you using VNC, SSH,and is it direct or through the browser?


#6

Hey Woolfel, yes, we have gotten around this by updating our advanced communications program. You can control which one you want to use (serial or BT) but you can’t use both. As you point out this is an issue with the hardware on the new Pi 3 and not something we have a way to control unfortunately.


#7

@CleoQc
when using VNC, the password is robots1234
thru ssh it doesnt like it
Rudi


#8

@CleoQc
Sorry, forgot to say that only for ssh direct the password is not accepted. When using the browser and selecting the Terminal, logging in with pi/robots1234 works OK.


#9

@Kaasneef, I just logged in to Jessie using both the terminal (putty from windows) and the browser (shell) and vnc. All three seemed to work fine with the pi/robots1234 combo . . . hmm.


#10

@John
something i must be doing wrong …
terminal (from my Mac El Capitan) doesn’t work (see attached screenshot), and i am 150% sure i entered the correct password
from the browser, both terminal and vnc work OK.


#11

Hmm. Looks like you changed the hostname from dex.local to pibrick.local?


#12

Hi john,

Cool. If I grab the latest BrickPi drivers and install them, I should be able to configure it and get it to work. I’ll give that a try in the next few days.

peter


#13

Looking at github, I don’t see the changes to BrickPi or BrickPi_Python. Where is the advanced communications program?

thanks

peter


#14

Hey peter,
The Advanced communication options is enabled by a GUI on the desktop. Here is the link to the source code https://github.com/DexterInd/Raspbian_For_Robots/tree/master/advanced_communication_options . Right now it allows you select either UART for BrickPi, or Bluetooth or IR control.

-Karan


#15

thanks Karan, I will take a look this weekend


#16

@kaasneef: I’ve double-checked and it’s robots1234 from everywhere I try to log in. Browser (VNC and terminal), Putty, ssh, even direct connection (screen and keyboard)
The pi user has its password set to robots1234 (that covers all forms of logging in via ssh and variants thereof)
samba has it too.
VNC is set to robots12 (the ‘34’ can be entered, it will simply be dropped by VNC - max of 8 characters in the password)


#17

Hello,
I apologize if you find my question strange but i downloaded the file 2016.04.25-Dexter_Industries_jessie.zip and when I unzipped it on my Mac I get a file named like this: 2016.04.25_Dexter_Industries_jessie.zip.cpgz

I tried to rename the extension as img and copy it on the SD card, but after launching my robot nothing happens, so I tried to copy the file on the SD card without changing the extension and nothing happens either. The Raspberry does not show up on my screen.

I have two questions regarding this situation:

Is there something I should do with this file before running this command? sudo dd bs=1m if=2016.04.25_Dexter_Industries_jessie.zip.cpgz of=/dev/disk3

Is this release supposed to work on Raspberry Pi model B ?

thanks


#18

jsv, you need to use a program such as TheUnarchiver to get to the .img file


#19

Agreeing here with Tracy, I think your program is upacking the packed img file into something else other than an img file. You might try a different program.


#20

Downloaded 2016.06.26_Dexter_Industries_jessie.zip twice. Once from SourceForge, once from Google Drive. Both fail to unzip. I tried Mac’s Archive Utility first, then unzip followed by gunzip. The command line unzip seemed to give the most informative message.

As noted by jsv the archive utility rearchived the file as a cpgz file instead of extracting the image.

III:2016.06.26_DexterIndustries_jessie cjl$ unzip *.zip
Archive: 2016.06.26_Dexter_Industries_jessie(1).zip
warning [2016.06.26_Dexter_Industries_jessie(1).zip]: 76 extra bytes at beginning or within zipfile
(attempting to process anyway)
error [2016.06.26_Dexter_Industries_jessie(1).zip]: reported length of central directory is
-76 bytes too long (Atari STZip zipfile? J.H.Holm ZIPSPLIT 1.1
zipfile?). Compensating…
skipping: 2016.06.26_Dexter_Industries_jessie.img need PK compat. v4.5 (can do v2.1)

note: didn’t find end-of-central-dir signature at end of central dir.

Any suggestions?