Latest Cinch image does not boot


#1

Rasberry Pi does not boot from the latest Cinch. I tried downloading and flashing it twice on a new SD card; nothing on the screen and no dex wifi. I’ve tried powering with both RPi power supply and BrickPi battery pack; red RPi power LED is on, and BrickPi power LED flashes 1 Hz – so power is not the problem. Everything works fine with my Raspbian SD card. Other details:

  • 2017.06.21_Dexter_Industries_jessie.zip
  • Raspberry Pi 3 model B
  • Dexter-supplied wifi dongle
  • BrickPi3

#2

Hi @dthomas,

I’ve noticed your post and I need to test it before I come to a conclusion.
Please give me some time until I get to something.

In the mean time, could you share with us more details on what procedures you have followed?
A step-by-step model would be really great, as that allows us to pinpoint the issue a lot faster.

Thank you!


#3

Thanks for the reply. I was just following the basic procedure (as here) but with the Cinch image download. So:

  • Download image from sourceforge (I also tried downloading the Google Drive copy with same results)
  • Flash to 8 Gb SD card using Etcher.
  • Insert SD card in Raspberry pi (which already has the BrickPi3, monitor, keyboard, wifi dongle, etc. attached).
  • Power up Raspberry pi using 2.4A power supply (I also tried using the BrickPi3 battery pack as well).

#4

Hi @dthomas,


I’ve tested it out and it works on my setup.
My setup is composed of the following elements:

  1. A Raspberry Pi 3.

  2. Dexter Industries-supplied power adapter.

  3. 2017.06.21_Dexter_Industries_CINCH.rar image.


In the first post of this thread, I can see you’ve mentioned using the 2017.06.21_Dexter_Industries_jessie.zip image instead of 2017.06.21_Dexter_Industries_CINCH.rar image.
There is a big difference between these two as the first one won’t work for you, but the latter one will do.

Can you check the sourceforge link again and see if you had used the correct image?


Thank you!


#5

Yes, tried again with the 2017.06.21_Dexter_Industries_CINCH.rar file and still nothing.

(I had copied the wrong file name into my post with the …jessie.zip – sorry for the confusion; I am indeed working on the Cinch image here.)


#6

Hi @dthomas,


All the odds should have been in our favor.

The RaspberryPi should have booted up and start broadcasting the dex AP, but it doesn’t.
This makes me think there is something with the Raspberry Pi itself.


I can think of 2 tests for now.

  1. Remove anything that’s connected to your Raspberry Pi, including the BrickPi. Then, test it again and tell us if there’s a change.

  2. Can you burn a Jessie image on your micro SD Card, plug it in the Raspberry Pi and tell us if it boots up correctly on your monitor?


Also, do you have any black-foam sticked to your BrickPi?
The black-foam on a BrickPi causes continuous reboots if it isn’t removed.


Thank you!


#8

@RobertLucian Thanks for the reply. The Raspberry Pi has been behaving as normal when I use my other Raspbian Jessie SD card. Since that works, I don’t think there is a problem with my unzipping, flashing, or R Pi. But I have yet to try flashing the Cinch image on a different SD card – so will try that next.


#9

@dthomas - just wanted to hop in with two more things. @RobertLucian is doing an amazing job:

  • When you run your setup, do you ever see any blinking on the wifi dongle?
  • When you boot, can you try plugging in a monitor before you turn on? That should tell us really quickly if it’s booting up properly.
  • Just for reference, here’s a video of what a proper bootup looks like on the Pi. Do the lights on your Pi behave the same as the video?

#10

@JohnC I see that it does boot up now, bringing up dex. I was able to get onto it through VNC & ssh. However, the screen is still blank. (I have a monitor connected to the HDMI port, which works fine with my Raspbian jessie boot.) From your comment about a monitor, I assume that the video output is not supposed to be disabled with Cinch?


#11

Hi @dthomas,

Video output is not disabled for Cinch, so you should get something on that HDMI cable.

Though, you need to make sure you’ve connected the HDMI cable to a monitor prior to booting up the Raspberry Pi as otherwise, nothing will show up on the monitor.

Thank you!