Line follower sensor not working


#1

I am having trouble using the line follower.
In Scratch the Cat says Technical Difficulty
And in python I can see that the call to get_sensorval() is not working
The print command before this call was working fine
And the print command immeditaely after this get_sensorval() call is not working
Any help is appreciated in this regard


#2

Hello @shivani.karol
Can you give us a few more details?
Are you running on a GoPiGo3 or a GoPiGo2?
Are you using Raspbian for Robots, or is this your own installation on Raspbian?

Thanks for the details.
Cleo


#3

Gopigo3
Using raspbian
Could you also confirm if the below line track is good enough for running the line sensor example? I tried both Line follower python and scratch example but none worked on this.
Line following track downloaded from -
http://robotsquare.com/2012/11/28/line-following/
And using the track - ‘Basic Test Pad’ - Printer Page Number field: 2,2,2,2,3,3,3,3,11


#4

@shivani.karol.

Did you install the code required for outside sensors?
For installation, run
curl -kL dexterindustries.com/update_sensors | bash

As for that track, it’s almost good enough. It’s possible for it to fall perfectly between two of the five sensors, and then the line follower wouldn’t detect it.

Cleo


#5

Yes I have installed through the same curl command.
What could I be checking on next?


#6

Hi @shivani.karol,

You say you are using a Raspbian distribution and not ours. In this case, can you check if the I2C interface is enabled? Do it with raspi-config.

Thank you!


#7

when I use the line callibration present on pi desktop, and ask it to read line position then on white surface it reads all 1,1,1,1,1.
What could be the reason for it?


#8

Just to be sure I’m understanding properly, you ran a total of 2 curl commands?

curl -kL dexterindustries.com/update_gopigo3 | bash
curl -kL dexterindustries.com/update_sensors | bash

#9

Thanks
It made the technical difficulty message go away.
But now the problem is that while doing line calibration, it always senses white as 1,1,1,1,1
Could it be because of shadow of sensor on white surface?


#10

Hello @shivani.karol
Did you calibrate the line follower? You should have a Line Follower calibration icon on the desktop.

Cleo


#11

So 1,1,1,1,1 is the output of line callibration desktop tool only.
But I have managed to get this fixed after giving the sensor a lot of colors.
Now its giving 0.0.0.0.0 for all white and all 1’s for all black.
Thanks for your help.
If possible please look into the other thread that I have created today for the error that I am facing while installing Open CV.
Looking forward for your help -