Login does not work after update


#1

I updated the BrickPi3 and now I get a credentials box (name / password) which will not accept my credentials nor the original default name / password. However, I can remote in successfully but command line only, I was even able to run the BrowserBot program.

I still cannot get the Desktop to display via remote.

I did install & run TightVPNServer hoping it might give me a desktop via VNCViewer and I wonder if that may be the culprit; however, I removed it and rebooted but still cannot get past the login box.

I solved this by re-writing the SD with the latest image. Luckily there was little on it of my own so no real harm done; good learning experience. Would still like to know what might have broke & how to fix it.


#2

Hello @bullerwj
Were you using Raspbian for Robots? It does come pre-installed with tightvncserver. If you installed your own, then you inadvertently changed the password on it. I have no way of knowing what that password would have been.

Since I don’t know what was your starting point, it’s hard to say what went wrong, but I’m happy you fixed it! :+1:


#3

Duh; I should have checked first. That is exactly what I must have done.

So how do I run a Scratch script without the a screen?


#4

@bullerwj,
if you use Raspbian for Robots, everything is installed for you already.
Once you have your robot connected to WiFi, you can use your browser to go to http://dex.local
Or you can use VNC viewer. The name of the server would be dex.local:1

Hope it helps,
Cleo