Motor problems with Scratch


#1

I am having a problem getting Scratch to run the motor on my BrickPi. After a lot of trying and research I can across the start up sequence (Start Scratch, load program in this case the motor test program, the sensors show to be loaded in the terminal window and I have run the BrickPiScratch.py program). I still get no response from my motor. It is an EV3 motor, but that’s not suppose to be a problem as it is the only thing I am trying to run. On the off chance it might have been a problem I hooked up a NXT motor to it with the same results. Any suggestions as to what I might try next? I am hoping I am making a programming error, but I have five of the BPi blocks in case it might be a hardware problem.


#2

Hey redkcirc,

Yes, you should be able to use the EV3 motors, no problem.

Are you using the DI image? What’s on your SD Card?

Have you tried running any of the motor sample programs we have in the Scratch directory?

Have you tried running any of the python test programs? If possible, could you run the motor test program to make sure that the BrickPi is working properly? These are a little more robust than the Scratch program.

Please let us know!

John


#3

Thanks for the reply. I didn’t have any success running it in Python although I got an error that suggested I might have a problem with the board its self. This proved to be the case. I replaced the BrickPi board with a new one and it works. Like I said I bought a half dozen of the BPi boards last year to try and integrate them into my summer computer/robotics classes. Due to problems with the people running the money we didn’t get our stuff until the end of the program so we didn’t get a chance to use any of them. We are running the EV3s and I also use the PiFace. This year I want to get them running and add the Arduino to the mix as well. We hope to be upgrading to the RPi 2 this year as well funding permitting.


#4

Ok, good to hear the software is working.

If we shipped you something that doesn’t work, can you contact us here: http://www.dexterindustries.com/site/?page_id=65

We’ll make it right.