Motor senors bad


#1

Love the idea of using RPI and Brick PI to build a robot. Got mine Christmas Eve and started having fun. Quickly ran into problems with the motors not responding. My sons and I tested several of the example programs and nothing would spin the motors. LED.py works so the RPI and Brick PI are talking. We can spin the motors by making connections to the GPIO pins. Checked all 4 sensors with 3 different motors. Based on 'motors example problems" posted on the forum we tested as he did and seem to have the same issue. What is the return policy so I can get a fully functional Brick Pi?


#2

Hey Les,

I’m sorry to hear about the problems with the BrickPi, especially on Christmas Eve. Bummer.

Can I ask a few questions before we pronounce the motors dead?

First, are you using the Dexter Industries BrickPi image, or other?

Other than the LEDs, did any of the sensor examples work? The LED’s are directly connected to the BrickPi, so they don’t indicate whether the BrickPi and Raspberry Pi are fully talking.

Can you try one of the touch sensor programs on it? If that works, it means they’re talking, and indeed the motor chip is damaged.

If it doesn’t work, we can try walking you through communications setup.


#3

We used the Dexter Industries BrickPi image but to be sure we rebuild the Dexter image again. Clean install and testing 3 motors in all ports still did not spin a motor.

I haven’t purchased any sensors, just the motors so I can’t do a sensor test. Any other way to test the communications setup?


#4

Can you open up the file “BrickPi.py” and un-comment line 48:
Change # DEBUG = 1 # Remove to hide errors
to `DEBUG = 1 # Remove to hide errors ’

All we’re doing above is removing the “#” symbol. Save and retry the example.

What error to you receive when you run the motor example?


#5

Turning on DEBUG showed no errors. When I put the code in IDE debug mode it turns out it never getting into the first loop. I worked on the indentation and removed all spaces and converted them all to tabs. Now it works.

I need to download your original LEGO-Motors_Test.py and try it. Right now I’d say the root cause was me creating a bug in the code.

Thanks for the help.