Motors and Sensors not responding

c
brickpi3

#1

I’ve been using the BrickPi3 for the last 3 months and its all working fine. I haven’t used it for the past week and motors and sensors stopped responding.

I have checked whether I have connected to the right ports and the battery voltage (11.93v) etc, everything seems fine. I have turned ON switch. All LED’s are working fine (Not rapidly blinking). All my code is running fine but the motors and sensors are not working.

The only strange thing I encountered is my encoder position of PORTA motor is returning 67888.
Only good thing for me is that at least BP.get_motor_status (PORTA,…etc) is working and returning some value.

Below is the output of the info program in C language

If I’m using the following program the motor is not moving at all. The output is always returning "the position is 0"

It suddenly stopped working.
Its almost end of my project and I have built an assembly line using LEGO motors and LEGO educational set. Help me out asap.


#2

20% power is not a lot; possibly not enough power to make the motor start running (or at least not within 250ms). Try applying 100% power and waiting 1 second before the loop to see if there is any difference.

Unless you reset the encoder values, they will accumulate over the power cycle of the BrickPi3. They don’t automatically get reset at the start of the program, and they continue to keep track even when the user program isn’t running.


#3

Thanks Matt for replying.
Coming to the problem , I have already tried it with 100% power and now I tried for 1 sec before the loop but the encoder position is still showing zero.
I couldn’t understand one thing for sure, even though I move the motor by hand the encoder position is not changing.
So I’m worried that the ports are damaged or something wrong was happening.

Thanks


#4

Are you certain you have the motor connected to the correct port? If you are using PORT_A in your code, the motor should be connected to the blue “MA” port in the image below.

Also, just to make sure, are you using an NXT or EV3 motor connected with a Lego 6-pin motor/sensor cable?

To try to figure out where the problem is, can you try another motor port, with another motor (still NXT or EV3) and another cable?


#5

Thanks Matt,
Yes I have connected EV3 motor connected with a Lego 6-pin motor/sensor cable. I tried every port but I don’t know it might be because of cables too, I don’t have any right now with me but I’ll try it over the weekend and will update you.

Thanks for your support.