Moved: Reply To: BrickPi- Lego sensors- no response


#1

I have exactly the same issue - http://www.dexterindustries.com/topic/serial-error-with-birckpi/

I have got the LED test to work, however when I try any of the example code for using sensors or motors they all fail. Sometimes with an error message (as in that link) but normally with no response. (other than the ‘print’ command working in python telling me something is meant to happen).

It looks like there may be ‘feature’ of raspbian that sends log-in prompt information on the serial pins; but that interferes with the connection between BrickPi and Pi [as that tries to use the pins). There is a fix to turn this off manually in the older version of the SD card-image (i.e. older version of Raspbian) and that seems to have worked for someone else.
http://www.hobbytronics.co.uk/raspberry-pi-serial-port
However I can’t get it to work on the current edition. I’m going to try tonight (or tomorrow) to use an older image and see if results improve. If you can do the same you may want to try that.

I have one of the first ‘modelB’ Pis - I imagine there may be some small differences to how Pi2 and Pi3 (models A or B) work that mean the problem isn’t experienced by everyone.


#2

Hi Tim, I’m moving this to a new thread since you may feel like you have the same issue, but it might be different.

First, what version of Raspbian for Robots are you using? If you’re using our latest Jessie image, you should update. We fixed a major bug in the software last night.


#3

Thank you understood -

Ok well I got the “2016.03.20-Dexter_Industries_wheezy” to work; I just had to turn the IR sensor off. [as described here http://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/ ]

(or at least I confirm the motor test worked - I didn’t check everything but that worked). So at least if the newer system doesn’t work I have ‘a’ version of the OS that works.

I will now try the “2016.04.25_Dexter_Industries_jessie” image again - and run the desktop update like you said… [I’m going to try and just only use the updater on the desktop – just in case combining it with the apt-get update command doesn’t work… ]

btw not a big thing, but I have found that when I try to run the example scripts in IDLE it complains that the indenting hasn’t been done right [mixing tabs and spaces]. I assume this means you don’t use IDLE so hadn’t noticed, but it may be helpful to do some kind of replace-tabs-with-spaces command on all Py files just in case it stumps people noobier than me.


#4

Hi Tim, glad to hear it worked out.

btw not a big thing, but I have found that when I try to run the example scripts in IDLE it complains that the indenting hasn’t been done right [mixing tabs and spaces]. I assume this means you don’t use IDLE so hadn’t noticed, but it may be helpful to do some kind of replace-tabs-with-spaces command on all Py files just in case it stumps people noobier than me.

Got it. Yes, we don’t use IDLE that much. We have an old tutorial somewhere I think. Thank you very much for the tip!


#5

I see the latest posts on here: http://www.dexterindustries.com/topic/brickpi-lego-sensors-no-response/
I also had that problem with Jessie - i.e. it worked for a bit and then a those error messages came up.

I had assumed last night it might just be the batteries were running low and so put them on charge, however based on your response I’m sticking with my SD card based on “2016.03.20-Dexter_Industries_wheezy” for now. I dare not use the updater until the details of this serial error is fixed. [although if you have an image or similar you’d like me to test on my hardware I’ll be happy to].


#6

Hi Tim,
Team just got a solution for Jessie. If you want to use Jessie and the BrickPi, you need to disable the serial console. Basically, you’ll need to edit /boot/cmdline.txt and remove any references to ttyma0

This is what /boot/cmdline.txt should look for the BrickPi to work on Jessie: dwc_otg.lpm_enable=0 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

We’ll publish a new Jessie image shortly.