My BrickPi Died. :) [SOLVED]


#1

pi@raspberrypi:~/BrickPi3/Software/Python/Examples $ python3 Test_Connected.py Communication with BrickPi3 unsuccessful

And here’s the output of the firmware update:
FirmwareOutput.txt (1.8 KB)

It doesn’t look to good.

It appears to be an issue with the SPI
import brickpi3 BP = brickpi3.BrickPi3() Traceback (most recent call last): File "/usr/local/lib/python3.4/dist-packages/brickpi3-0.0.0-py3.4.egg/brickpi3.py", line 293, in __init__ File "/usr/local/lib/python3.4/dist-packages/brickpi3-0.0.0-py3.4.egg/brickpi3.py", line 409, in get_manufacturer OSError: No SPI response

I know your thinking it can’t get any worse but it can!
When I flip the power switch off there is not a single LED on, or even blinking.
But on they all shine, blink normally.

It appears that after I updated the firmware all of this happened.

@Matt


#2

Oh never mind. I realized that I didn’t realize that the BrickPi3 loosened up a bit so it lost a good connection with the GPIO pins. Now I was able to successfully update the BrickPi3! Everything works now except the motors. Which I made a thread about that here:
http://forum.dexterindustries.com/t/the-motors-do-not-turn-but-are-held-in-place-and-do-provide-feedback/3217


#3