No sensors or motors. Otherwise good


#1

Hi there,

I am trying to get my BrickPi started. Everything seems to work great, using the Dexter Industries SD card. I can connect with WiFi, VNC remote, etc. Getting online is no problem and I’ve updated/upgraded with sudo apt-get update no problem.

Using 8 new AA batteries and the USB I can get the LEDs to flash but I can’t get any response from any of the three motors I have plugged in or the touch and ultrasonic sensors. I’ve tried going at it from Python and Scratch, but to no avail. Attached please find the screenshot when I run sudo i2cdetect -y 1 from the terminal.

Please let me know what the next step should be. I can’t find anything else.


#2

Hey Red,
Great to hear everything is working other than motors and sensors.

Running i2cdetect won’t detect anything with the BrickPi; it runs on a serial protocol.

Can you test the motors: if you run the motor test program under /BrickPi_Python/Sensor_Examples. Two samples:

  • LEGO-Motor_Test.py
  • LEGO-Touch_Sensor_Test.py

What happens when you run either of these?


#3

Sure, sorry I forgot to mention that part!

Basically the files seem to run fine but nothing happens with the motors or if I press the touch sensor. Then I hit Control C to get out of the program.

I’ve attached a screen grab from a few of these tests.


#4

THat’s really strange there’s no response. Another question:
I wonder if the BrickPi is responding at all; if you run the EV3-Firmware_Check.py, do you get a response at all?

If this is defective hardware, or there’s a problem with the hardware, we’ll replace it immediately.


#5

Thanks for the help, John!

Here is what I got after running the file.


#6

Hey Redwagon, this seems to show that the latest version of firmware isn’t on your BrickPi, or you’re not communicating with it properly at least.

Best way to handle this is to replace the hardware. I would like to do a swap if it’s possible, and Amber can arrange that. I’d like to see why this isn’t working (put a logic analyzer on it, etc).

Can you contact us on this address: http://www.dexterindustries.com/site/?page_id=65

And reference this forum thread. We’ll make it right immediately.


#7

Sounds good, John. Thanks again for the help!


#8

I’m going to close the thread. However, please let us know how the replacement works out. I think it was a hardware problem, looking forward to seeing what happened with your device.