No Serial Ports Appear To Be Working


#1

Hi, I’ve recently set up the BrickPi although the serial ports do not seem to be working. I’ve tried motors on all motor ports and a colour detector on a few of the sensor ones as well and when running example programs either in scratch or in python, the motors did not run. Also when I had the colour sensor plugged in the light on the sensor did not turn on. I’ve tried powering it both by micro usb and batteries and I imaged my sd card a few days ago.

I have made a copy of the driver that is provided and made changes to it to support python3 and I thought that may be the problem until I tried in scratch with example programs where that didn’t work either. Is there a setup step I gave missed or something that may not have installed correctly in the setup process?


#2

Hey Jimmybobtm, are you using the Dexter Industries image?

The most common issue is that the comms have been disabled. Have you given this a shot: http://www.dexterindustries.com/howto/enable-or-disable-brickpi-communications/

?


#3

Sorry, and if yo’re not using Raspbian for Robots, I would recommend you at least test with it. You’ll need a 4GB SD card:

http://www.dexterindustries.com/howto/install-raspbian-for-robots-image-on-an-sd-card/