No SPI Response Error when trying to read sensor


I am trying to replace Raspberrypi with Zynqberry and communicate with Brickip3.
I want to stack Brickpi3 on top of Zynqberry board (TE0726-03M) and read the lego sensor connected with brickpi3.
I followed the mentioned steps in the below website to download Brickpi3 repository

Currently, I have established spi communication in board and when I run script in the pre-built Examples folder (Dexter/BrickPi3/Software/Python/ it gives a message ‘Brickpi3 connected and running’.

But when I run sensor example program and Read info program, it gives an ERROR message ‘No SPI Response’


Since the SPI is running, I believe I have to configure SPI correctly for Brickpi3.
Can someone please provide me with SPI configuration Brickpi3 uses (Clock Frequency, Clock polariy, Clock Phase, etc.) ?

Thanks for your time and consideration.

1 Like

Hi @dpkrr07,

I don’t have an easy answer for you, but I’d be happy to bring this to our team so we can do a little digging. Please send a summary of your issue and any updates to our helpdesk (

Please let me know if you have any questions,

1 Like

Thanks @mitch.kremm for the reply.
I have dropped a mail to the support team you have mentioned.

Meanwhile I would like to update the thread.

After configuring SPI, currently, I am able to communicate with Brickpi3 and read the sensor value from the Zynqberry board.
But, the current issue is I want to install the lego drivers. Currently, I am referring the below website. But I am not entirely sure of the steps.
It would be helpful if you could share any insights if you had done anything similar.

Thanks for your time and consideration.

1 Like