None of the motors or sensors are working


#1

I bought the Brickpi kit & Groovepi and received it last week. I started out with the Brickpi shooter project and assembled everything as per the instructions & build the lego model as well. I was able to successfully connect to the RaspberryPi from my computer as per the instructions. However on running the python program for the shooter I could see the recording of the mouse movements and the right/left click on the screen but the motors would not do anything. I looked through all the troubleshooting articles in the forum and tried everything from changing the batteries for the brickPi to using the power cord for the raspberry to using the second SD card provided in the kit to dismantelling and reassembling the brickpi and now after 2 days of continuous struggle I have given up and hence writing in the forum as this is the only means to get help. Need some engineer from the company to help. I was expecting that the hardware should work right out of the box!


#2

Its probably just a bug with that script. So lets see what some others do to verify if your BrickPi3 works.
can you go into a terminal and run the Test_Connected.py script?
It is located in the BrickPi3/Software/Python/Examples folder.
To run it just type this into a terminal:
python3 /home/pi/BrickPi3/Software/Python/Examples/Test_Connected.py
If it says its connected then great and then lets try the motors.
To do that run LEGO-Motors.py
python /home/pi/BrickPi3/Software/Python/Examples/LEGO-Motors.py
You’ll need to plug in a touch sensor into port one and a motor into any of the ports before running.

I don’t work for Dexter Ind but would be happy to help you get it running.


#3

Hello
Did you get a BrickPi3, or a BrickPi+ ?
The shooter script is written for the BrickPi+ and will not work as is on a BrickPi3.

Cleo


#4

I wanted to add that If your BrickPi has a power switch its the BricjPi3, if not you got the BrickPi+.


#5

I bought the latest and greatest Brickpi3. So the code will not work for Brickpi3 for the shooter project! Is there a code that will owrk for Brickpi3 for the Shooter project?


#6

Also non of the troubleshooting scripts provided would work - i tried the touch sensor example code, motor example code, hardware test codes but non of them would make the motor move or sensors to provide the necessary inputs. Please help!


#7

We haven’t ported all the projects to BrickPi3. And you have to make certain that the code you’re trying is for BrickPi3.

Have you tried the links that @graykevinb gave you a little higher up?


#8

I have tried those examples suggested by graykevinb and other examples too - touch sensor etc. But nothing seem to work. Please advise! Seems like the brickpi is not working with any example.


#9

Ok on further investigation the SD card I bought with the kit does not have a Brickpi3 folder. Please advise how to get that. Also I m logged into Raspberry pi using the VNC


#10

OK, I installed the Brickpi3 directory and ran the test_connected - “communication with Brickpi3 unsuccessful”. I also ran the Lego-Motor.py and got error message “IOError: No SPI response”

The Brickpi green light is on. The Brickpi yellow is blinking 1/second. Raspberrypi3 has red light on and yellow blinking.

Please advise next steps


#11

How did you install the BrickPi3 directory? Did you run the DI Software Update, or did you do it manually as described here?

Try running the Read_Info.py example.


#12

I did it manually as described on your website.

Output of Read_info.py is “No SPI response”

Please advise next steps


#13

Try running the DI Software Update on the desktop, and then click Update Dexter Software.


#14

DI software update window opens up and says

Xlib: extension “RANDR” missing on display “:1.0”

Check for internet connectivity…

[]


Just sits there and does nothing even though wireless is connected


#15

Hello @ripujeetsharma
there is a sizable delay when starting DI update as it’s transferring quite a few things from Github. Depending on your connection it can definitely take minutes. How long did you leave it for?


#16

ok - after a long while it installed the update.

On running the Read_info.py i got an output saying " Brickpi3 needs to be version 1.4.x but is currently 1.0.1


#17

You can either update the firmware using DI Software Update, or by following the instructions here.


#18

i also ran the test_connected and LEgo_motors with the same results

Brickpi needs to be 1.4.x but is currently 1.0.1


#19

That’s because the drivers are newer than the firmware. Refer to my last post for updating the firmware.


#20

OK. It works now!

By way of background, I have been coaching FLL & Jr FLL teams for the past 7 years and wanted to introduce python programming using EV3 & Mindstorm models in my STEM enrichment center & found your product. I was planning on buying at least a dozen or so of these kits.

I bought this one trial kit because i want the thing to run out of the box thinking that if i bought the kit it would have your SD card with uptodate software etc. However my whole experience has been otherwise and i have lost 4 -5 days in this process. Would it not be better to send updated software in the kit? Or if this is not possible would it not be good to send some instructions on how to update the software before beginning the project? Also nowhere on your website does it say that the shooter will not work with the Brickpi3 - if i had known i would have bout the older version maybe.

I had to do a lot of guessing and your handholding to get to this stage. Please advise what Projects are possible with brickpi and what projects are possible with the older versions so that I can plan to buy the right stuff.

Ripujeet