One side not working


#1

Hello,

I got my BrickPi from Kickstarter project, everything worked fine but 2 days ago motor D stopped working and sensor ports 3 and 4 are showing 0 value when asked.

The other side works fine, leds work fine, 5th sensor too… I tested it using different scripts so I am sure problem wasn’t with my script.

My suspicions are something went wrong with controller. Is there any software or easy way to repair it without sending it to US, since I’m from EU ?

I tried to update/upgrade, reboot the system but it happened suddenly from day to day so I’m helpless.

Thanks in advance for your response.


#2

Hey Zoidbergus, first, sorry to have so many questions.

You mention that the Motor D stopped working, I’m assuming that Motor C doesn’t work either, but can you check?

What sensors are you running on Port 3 and 4 that return 0? Also, what example or code are you running (just want to be sure it’s not a code problem); have you tried using the original example codes we have in our github repo?

Also, you said update/upgrade: what version of the BrickPi image are you using (which date)? If it’s not the latest, is it possible to update to the latest before doing the Motor D test?


#3

Hi,

So I checked motor C and it isn’t working either. For Ports 3 and 4 I used Ultrasonic sensor using example scripts which worked before (modified for right ports). I am using Wheezy system with installed BrickPi from github from 2 months ago.

However, when I plugged in the Ultrasonic sensor to Port 4, I could hear really quiet noise, but not as loud as when it was in Port 1 for example. Also, H-bridge smells different from Raspberry Pi so I assume something went wrong with it.

After that, I measured Voltages on RJ12 cable, port 4 had values 5V, 5V, 5V, 0V, 0V and 0V and port 1 had 5V, 5V, 5V, 10.6V, 10.6V and 10.6 V.

I already found another H-bridge SN754410NE nearby, should I buy it and try to replace it or do you think the problem is more severe ?

Thank you.


#4

Thanks for taking all those measurements. Is your supply voltage at 10.6? Because on looking at the port values, you might have somehow shorted something on the board (looking at the last three values of Port 1, that looks like it might be connected to the power supply somehow).

Port 1 shouldn’t be connected to a motor port, but could something have shorted between the motor port and the sensor Port (like a stray wire or something else conductive that might have fallen in)?


#5

Hi,

now that you mentioned short-circuiting the board I remember accidentally plugging in the battery while it was powered by Raspberry PI and it made cracking noise on the connector, but I am not sure if that is the reason it stopped working. I am using 10,8V NiMH akku 4600 mAh (works fine for 3 weeks between recharges). I checked for random wires but there wasn’t anything except occasional dust.

Anyway, I made some more measurements according to RJ12 cable wires documentation, there are relations between them. I measured voltage between wires 1 and 2, 3 and 4 and between 5 and 6.

These are the results:

Using (asking) Ultrasound sensor:
Port 1 voltages: +10.6V, -5V, 0V
port 4 voltages: +5V, -5V, 0V

Motors running forward (at “200” speed):
Motor A voltages: +9.5V, -5V, 0V
Motor D voltages: 0V, -5V, 0V

this seems like “-5V” part is supplied by system which is good, “0V” between wires 5 and 6 is always there but between wires 1 and 2 are different values. Port 1 and Motor A are working. Easiest option seems to be to replace the Half-H driver at the side of Port 4 and if it doesn’t work I don’t know what could help. What do you suggest ?

Thanks.


#6

I am using the GoPiGo for connectome research and I am seeing the same issue. Both wheel motors work but now the left side of the motor control board will not work when I send it commands. I was experimenting last night and the robot got hung up and when I went to retrieve it, I could smell what was like electronic’s burning and the left wheel stopped working. I tried several attempts, re-applied the firmware upgrade again, etc but no luck. If I plug the left motor to the right side pins, the motor works fine. Any suggestions? Can I purchase a replacement?